Samsung SmartThings Link - a new Z-Wave and Zigbee USB combo adapter/dongle

Tags: #<Tag:0x00007f73afe985c0> #<Tag:0x00007f73afe98318>

Hardware tip for those living in the USA or Canada!

Samsung is offering their new SmartThings Link USB dongle for only $14.99 right now:

https://shop.smartthings.com/smartthings-link

These supports both Z-Wave and Zigbee but have no documentation so could only be used in Home Assistant if and when some clever developer manage to communicate to it via serial UART protocol.

Right now they also offer free shipping in the US for orders over $25 so tip is to buy one of the Smart Bulb bundles, starting at $34.99 including SmartThings Link USB adapter.

1 Like

Curious about this, have you bought one and tried pairing with HA?
If not, can Nvidia Shield owners just use this dongle and use the smartthings bridge for HA?

It’s only sold in North America so far and as we I live in Europe so have not bought one.

I’m hoping that they will announce a EU version for the UK at CES 2018 at the latest.

Samsung is unfortunately infamous for ignoring the European market on the IoT side.

I got mine and plugged it into a Windows PC and it installed a driver called Silicon Labs CDC Serial Port. I opened putty and tried to connect to Com1 with no luck. Any other simple things I could try. I’m not a coding genius.

If it uses a Silicon Labs chip then it might be use the same chips as the the HUSBZB-1 stick already supported by HA?

Nortek/Linear GoControl QuickStick Combo (“HUSBZB-1”) is a Silicon Labs based ZigBee & Z-Wave combo stick as well.

If so then you will probably need Silicon Labs CP210x USB to UART Bridge Virtual COM Port (VCP) drivers found here:

https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

Most posts in this community are about getting the “HUSBZB-1” USB adapter to work so suggest try following those.

So on Windows, i’ve tried using the driver you linked to with no luck. It installs the driver ok, but it says that the device cannot start. On linux, mine binds to the cdc_acm driver instead of the cp210x driver like I assume would make it work. I’m not so good with kernel stuff on linux and haven’t figured out how to change the binding yet. If anyone has some suggestions, I’d happily investigate! (My goal is to have it running on Linux on my chromebox instead of a raspberry pi.)

I’ll also report back if I find anything.

Sorry for the double post, but I’ve made a little headway.

I got the device to unbind from cdc_acm and bound to cp210x by running:

sudo modprobe cp210x
sudo tee /sys/bus/usb/drivers/cdc_acm/unbind <<<1-2:1.0
sudo tee /sys/bus/usb/drivers/cp210x/bind <<<1-2:1.0
sudo tee /sys/bus/usb/drivers/cp210x/bind <<<1-2:1.1

I got the 1-2:1.0 and 1-2:1.1 from dmesg and:

tree /sys/bus/usb/drivers

If I look at dmesg again, i can see the device linking to ttyUSB0 and ttyUSB1, but they end up with an error. Usually -32 or -71.

cp210x 3-13:1.0: cp210x converter detected
cp210x ttyUSB0: failed get req 0x4 size 2 status: 0
cp210x: probe of ttyUSB0 failed with error -71
cp210x 3-13:1.1: cp210x converter detected
cp210x ttyUSB1: failed get req 0x4 size 2 status: -32
cp210x: probe of ttyUSB1 failed with error -32

This is as far as I’ve gotten. I’m not sure what else to try. can anyone offer any suggestions?

Is there any update?

Not yet, no. I haven’t had a lot of time to look into it, but I haven’t given up. I will be posting my findings on the Silicon Labs forums as they are the makers of the CP210x chipset. Hopefully someone there can offer some guidance.

EDIT:

I’ve done a lot of research tonight, and I think we might be at a standstill. According to the Silicon Labs forums, the generic driver they provide should work for most devices UNLESS it was modified by the manufacturer. (IE: Samsung’s favorite hobby)

I’ve emailed Samsung’s Smartthings support line, all but begging for a release. I think if we want to see a driver, they will need a lot more than me to convince them. If you could, please also email them asking. Hopefully they will be compassionate.

You can contact them here: https://support.smartthings.com/hc/en-us

EDIT2: I spoke with the Smartthings Support on the phone and they recommended I post in their community. They informed me that the engineers occasionally hop on the forums there and help out. This may be our chance to talk to them. I’ve posted a topic there with my findings. Please help me convince them to release these drivers :slight_smile:

I agree with you. i think they’re not gonna let us :frowning: I guess the $15 was worth a shot.

I’m still hopeful something will happen someday. I’ll keep doing research, but it probably will be down the road a bit. I was trying to avoid it, but I ended up purchasing the Aeotec USB zwave stick. I just need to get my stuff running for the moment and don’t need zigbee support. Looking forward to running Home Assistant!

(New to home automation here) Does the Aeotec USB zwave stick only work with Aeotec zwave devices? Or does it work with all zwave devices?

So from what I understand, Zwave is standardized so anything with the zwave badge will work with other zwave stuff.

Zigbee is the one that’s not standardized so you have to watch out for compatibility.

I ended up purchasing a Linear HUSBZB-1 and I’m gonna give my SmartThings Link to my friend who has a ShieldTV

hey saw this topic hasn’t had any action for a couple years, but was there any progress on this? I have one sitting around, would like to hook it up.

Not supported yet and now so much time has passed that I would not keep any hopes of seeing any support for it in the near future or at all. At least now there are relativly inexpensive alternatives available.

As a newbie, I’m curious as to what your favourite of these “relatively inexpensive alternatives” is. I can’t seem to find a good list anywhere of USB dongles that have both Zigbee and Z-Wave.

Because there is only one,the Husbzb-1, and that one only works in north America.

Super helpful!
Thanks for the quick reply. :slight_smile:

The North America only limitation is frustrating - and a reason that I’m leaning toward building out around zigbee.

Thanks again.

francisp is correct that Husbzb-1 is the only compatible combo dongle available that supports both Zigbee and Z-Wave (and that the Z-Wave radio in Husbzb-1 is for North America only), but you also have to understand that the fact that there are no other combo dongles is not really a limitation, as if you think about it you will probably come to the conclusion that you do not want a combo adapter.

IMHO, best is to not have a combo stick. Ever heard the expression “Jack of all trades, master of none.”? The Husbzb-1 is not the best Zigbee dongle and it is not the best Z-Wave dongle, and for the same amount of money you can get a separate Zigbee and Z-Wave adapter dongles. Most would at least argue that it is better to separately have one dedicated adapter for Zigbee and one dedicated adapter for Z-Wave as it gives you most flexibility and easier upgrade paths. Regarding that it should be noted that the Husbzb-1 Zigbee have an older Zigbee chip inside it that is not very powerful and it is only compatible with ZHA in Home Assistant.

For Zigbee it depends if you plan on using ZHA, Zigbee2mqtt or DeCONZ. If you are on a budget then get an inexpensive Texas Instruments CC2531 dongle (preferably with an external antenna) as that is compatible with ZHA and Zigbee2mqtt, alternatively you could get a more expensive but much more powerful CC2652 dongle. If support for DeCONZ is your requirement then ConBee or ConBee II dongles is your only option, those are also compatible with ZHA and in development for Zigbee2mqtt but should be noted that they do not Zigbee 3.0 (however that is not yet an issue today). If you are sure that you will only use ZHA then a great new alternativly adapter is the Sonoff ZBBridge Zigbee-to-WiFi bridge as it is relativly inexpensive plus contains a very powerful radio and can now be hacked with a Tasmota firmware for ZHA compatibility.

For Z-Wave I currently recommend Aeon Z-Stick Gen5 for Z-Wave 500 series if money is no option (though next-generation Aeon Z-Stick for Z-Wave 700 series and other next-generation dongles is said to be ready for general release before the end of the year). On a budget, you can instead get the Z-Wave.Me UZB stick (which is also Gen5).