Samsung TV integration - we need to talk!

i’m new to both HA and python. Even with my limited experience with Samsungtv, the built-in and custom variations available, I understand the complexity and time involved in maintaining an inclusive component to satisfy all samsung models currently running. Establishing separate components for legacy, tizen or future systems that samsung will release seems to be the path to follow. Being a samsung legacy owner with a 2013 model, which works perfectly, should not be considered expendable and deprecated for HA.
The built-in integration for samsungtv works for me but it has limited functions with respect to source selection. I assume this is due to the supported version of samsungctl and the set source list in the component. I noticed that kdschlosser had developed a revised samsungctl with enhancements to expand the functions for a legacy tv. I have gone through numerous threads/posts trying to track down how to incorporate this into HA without much success. Any hints would be appreciated.

1 Like

Afraid I can’t be of much help. I note that the custom integration you’re referring to (presume this one) hasn’t been updated in 20 months (compared to the official integration and others). Might I suggest raising an issue with the official integration?

Found this link that I thought might be of interest to you all. Was looking for a list of ports for my IOT firewall rules.

F-Secure Labs did an in depth poke around a Samsung Q60 series smart TV this time last year.

Also a handy link on reddit of network ports but I’ve no doubt you’re each aware of them at this stage:

Is there any way to push messages to Samsung televisions? I have a Samsung UHD8 series. Pushing messages via call_service notify doesn’t work.

Afraid not… my personal advise going forward to any serious Home Assistant users, looking to buy a new TV, is to avoid Samsung. For similar quality TV with good HA integration and on-screen notifications, I will be choosing LG.

If you’re on a budget and in Europe, I hear the 50 inch Hisense R50B7120UK Roku TV is supposed to be excellent quality for price (€380) and communicates via MQTT (although I’ll admit I haven’t fully read into the quality of its HA integration).

1 Like

I actually fall In the bucket of having a 2012 (maybe 2013) and a 2019 as well.
So am in a position to test both legacy and tizen

I don’t remember what pre-tizen was called but believe it had a name (might be more appropriate than legacy) but clearly the older tv’s are slightly less capable in terms of what functions they expose. These TV’s still work great and I wouldn’t be deprecating them - maybe it’s even as simple as one integration being ‘pre-2013’ rather than legacy

If split - would there be any issues in discovery? My Tizen doesn’t currently discover at all.

Did plan on trying to have a crack at updating the tizen plugin but got a bit side tracked when I couldn’t even change the source (HDMI 1/2/3/4) without using SmartThings

Any help to get added my smart tv to HA, the discovery keep finding the TV but is not able to connect…
it’s a UE58H5203 here a portscan:

nmap                                                                                                                                                                         3412ms  Mon 31 May 19:25:46 2021
Starting Nmap 7.91 ( ) at 2021-05-31 19:26 CEST
Nmap scan report for (
Host is up (0.0073s latency).
Not shown: 996 closed ports
4443/tcp open  pharos
7676/tcp open  imqbrokerd
8080/tcp open  http-proxy
8443/tcp open  https-alt

PS. i never found an official app that allow remote control, the only “smart thing” that the TV does, is to appear on the Youtube app on the smartphone and i’m able to remote control the playback of youtube videos from the phone

on the 8080 and 8443 ports seems there is an http(s) server that reply with these headers:

HTTP/1.1 404 Not Found
Content-Type: text/html
Content-Length: 345
Date: Thu, 01 Jan 1970 00:30:05 GMT

on the 4443 another (broken) https server:

curl -k                                                                                                                                                        2146ms  Mon 31 May 19:39:49 2021
curl: (35) error:1401E410:SSL routines:CONNECT_CR_FINISHED:sslv3 alert handshake failure

@jaruba @ollo69 Any updates on your collaboration on @jaruba 's original integration? I notice there are still the two separate ones out there. I’ve tried @jaruba 's on my UN65H8000 and no luck. But I always default to “I’m doing it wrong” rather than the integration is wrong.

Also, if any testing is wanted I have these Samsung TVs:

1 Like

I have a SAMSUNG 2020 THE FRAME - Code: QA75LS03TAWXXY - available to test with.

to be honest, after testing a couple of components, jaruba among them, I wasn’t completely pleased. I’ve been using jaruba’s for more than a year, which is great, but recently certain features went down for my model and moved away to something else.

I ended up creating my own “integration”, mixing webCoRE (webCore only works for TVs showing up in Smartthings) with http requests and node red (I assume it can be done in HA as well) and putting everythign together with the universal media player integration in HA. I’ts not really hard, I’m kind of a newbie and it works worlds better than any integration I tried.

The tv updates every 5 seconds in HA and always sets the correct picture and sound settings for every source/app/whatever, which were my two main aims. Beyond that,webcore does feature a bunch of available commands not present in any integration. It would be great if we could investigrate webCoRE together in this forum because the majority of commands are straightforward but some aren’t and there’s not documentation about them in the webCoRE forums. We are probably missing something really powerful whithin webcore and it can be really easily triggered from HA. Here are all the commands available for my TV.

1 Like

I decided to open a new thread so whoever wants to come investigate is welcome:

1 Like

Another user with 2 TVs here, an older 2013 legacy one and a 2020 Tizen one. I seem to have the opposite problem of everyone else in that the new one works well with both ollo69 and jaruba’s integrations (thanks for the great work) but I can’t find one that will reliably report on the power state of the older legacy one. The official integration will pick it up but the power state flips between on and off when the TV is constantly on so it is no good for a simple automation to switch the back lighting which is all I am trying to do. Does anyone know of a integration that works on the older pre Tizen models and will reliably report state please?
Thanks Pete

UN40MU6290 and UN55KU6290 here. Certainly willing to test intermittently.

I haven’t gone down the path of checking out the implementations mentioned above but I will be looking into those with interest over the next few weeks.

I don’t know that any of you have tried this custom integration. I have an H series TV, an H6400, and it works well. This custom integration is actively developed as well, so there are fixes on breaking changes.

The story of the H series is that Samsung originally released with a non-ecrypted connection. It had a lot of awesome features like sending the TV screen’s content to your phone or tablet through the official app, then they removed the functionality probably because someone sued them for copyright issues if you send the content to another device.
Then they did a few firmware updates until they introduced and encrypted connection as well. SmartThings originally was supporting these TVs until the encryption took place. In SmartThings’ groovy code there is no way to do encryption like AES what the device required. These encrypted TVs are pre-Tizen, but not that much as the others, as they fall into a category in between the two.

The only downside of the H series TVs is that you cannot turn them on remote. You either need to use HDMI CEC or an IR blaster like a Broadlink device.

I hope it helps!


Tks for the info! By any chance do yu know if it’s still possible to revert back the firmware?

Unfortunately no idea. Try to search for SamyGo and read some articles on the old forum there. But why would you want to revert a firmware. Mostly nothing is supported there anymore…
I cannot really think any advantage of reverting the firmware on an old TV like the H series…

It is a nice 4 HDMI TV with 3D support, but any smart functionality is pointless anymore, except the integration to control it, but it works with the latest firmware.

1 Like

Thanks a lot for your quick answer.

I want to try roll back the flash as the official HA integration is not being useful and just as you mentioned at the end of your comment… “The only downside of the H series TVs is that you cannot turn them on remote” … I’m not being able to control anything at all about tyhis device … I do can see it state (on/off) but that’s it … i cant change the source, volumen turn it on/off… so as far as I understood you maaaybe with the past firmware it could be possible so I want to try as with this one is not possible

:slight_smile: Do you think it could work? Or by chance do you know any other integration that actually let me control the H series? Thanks again!

What I linked above that is working with the H series, but here is the link again:

Install it from HACS

About turning the TV on remote, it is a physical limitation of the TV. It goes to deep sleep and can only be waken up by either HDMI CEC commands or IR, like Broadlink.

the README is still talking about a and a PIN… but seems nothing work for my model… i’ve also opened an issue at time with no final solution

my final workaround was to use a broadlink IR … oviusly i have no “current status” of the TV

Have you ever connected your model to the SmartView app by Samsung?

Unfortunately the app has been decommissioned by Samsung and cannot be downloaded anymore from the Play Store, but that was one of the official apps to control the TV from the local network.

Here are some links for reference:

The other question is that your TV is running the latest firmware and was it ever supporting remote control from the app.