Scene editor - only save/send certain attributes to a device? (Philips Hue)

I’m scratching my head here, and hoping I don’t have to fall back to editing YAML files (which the HA team seems to be trying to deprecate in general?):

I have a set of Philips Hue RGB bulbs that are being controlled using the ZHA integration and a Nortek/GoControl HUSBZB-1. These bulbs support both RGB and CCT tuning. Which mode they’re in depends on the last command sent to them.

Manually controlling them in HA works fine - if I want a CCT, I click the CCT slider somewhere, and the bulb switches to CCT mode.

However controlling them as part of a scene does not - The scene editor saves the ENTIRE state of the bulb, and sends the state variables in HA’s own order, not the order that the user changed the state.

As a result - The RGB state of the bulb in the UI is saved, and it is always sent after the CCT state. This will put the bulb in RGB mode, and the CCT setting that was sent gets ignored.

How do I set it so that when a scene is activated, ONLY the CCT setting is sent to the bulb and not the RGB setting?

Everything I can find regarding Philips Hue and scenes here seems to be about triggering Hue scenes for users who have Hue bridges - one of the reasons I migrated to Home Assistant + HUSBZB-1 from a Vera + Hue Bridge was because Philips effectively bricked my Hue v1 bridge at the end of last month.

Not possible atm. You can create the according scenes via ui but then have to remove the unwanted attributes in the scenes.yaml

1 Like

I have a similar problem with a novostella flood light…Its been driving me around the twist…Its an RGB CC CW light that has been tasmota’d. I thought I had the wrong settings in it…but it looks like you have the same problems when returning to a scene the RGB takes priority and drops the CC CW values…It would be nice to get this resolved