Scene light transition does not work in latest versions

After an update I noticed that ‘transitions’ in Scenes are not working anymore.

I have entries in the scenes.yaml file like:

- name: Livingroom normal fade in
      state: on
      transition: 30
      brightness: 144
      color_temp: 360

The lights are Ikea Tradfri.

It worked well before version 0.100

Is the syntax changed or is there a bug?
The logs do not show an error like I had with cover positions.

Transitions have been removed from scenes, as have stateless changes. Scenes are basically pointless now. Convert it to a script.

1 Like

I tried to change it to a script but get an error: extra keys are not allowed.


Call Service

  brightness: 144
  color_temp: 360
  state: 'on'
  transition: 30

Also tried without state ‘on’ and got the same message.

If I remove the light.woonkamer, all the lights turn on :roll_eyes:

Yeah, you have to use the script syntax as you would with any other script

      - service: light.turn_on
          entity_id: light.woonkamer
          brightness: 144
          color_temp: 360
          transition: 30

That made it work as it needed to be.

So in short: Use scripts instead of scenes for most of the scene like settings.

Am I right?

You are correct :slightly_smiling_face:

For some reason it seems to work if all you do is change the color of a hue bulb (only tested on hue, don’t have anything else to test it on) but turning it off or on seems to ignore the transition. Makes me sad.