Schlage FE599 Door Lock Code Delete

I am having a bit of trouble, it seems, deleting a user code from my lock. I successfully added one to the lock, from the ZWave config within HA no less. However, it is not letting me delete it. I tried deleting the code from the ZWave config, and I tried using the services call clear_usercode with:

"node_id": 82,
"code_slot": 3,
"usercode": "xxxx"

It gives every indication that the command was executed but when I go to the door and enter the code it still works. Anyone have any ideas?

I’m afraid I’m not much help in this case, I just wanted to let you know you’re not alone. I have the same issue with the fe599. Adding codes works fine, but I can’t delete them from HA.

I think this lock is a bit of a different beast than the deadbolt models (my doors shift too much to use deadbolts reliably) that are talked about on here quite a bit, specifically in this thread: Schlage Connect ZWave Locks. I’ve never had any luck with the lock reporting anything on the “alarm level” or “alarm type” sensor entities that are created in HA; they’re always 0. I also poll the lock every 30 seconds otherwise HA doesn’t represent whether it’s been manually unlocked.

I’ve always hoped for a bit more time to look into this more but it hasn’t been a priority unfortunately.

Did you try it without the “usercode” parameter?

No sir, I did not

@tobas thank you for your input and information. It is very much appreciated

@StormStrikes When I do clear_usercode with the usercode, it doesn’t even send it to the zwave stack. When I do it without, it sends it, but it does nothing. I set a usercode for a slot to “0000” and somehow it deleted it. Let me try some more later…

Yeah, I tried doing it with and without as well to no effect. Though I could remove it manually if needed, I’d rather be able to do it from within HA if possible. It’s great I can add the code. I have waited some time for that feature to come to HA.

I suppose one thing I need to do is verify or somehow confirm the device was added in secure mode. Though I would assume it would not allow me to even add codes if it were not.

Right, you wouldn’t be able to open or close it if you didn’t securely add it. You could also tail the OZW_log.txt for this:

Setting Encryption Flag on Message For Command Class COMMAND_CLASS_DOOR_LOCK

That would be proof that you are using secure mode for that device. Try setting the code to 0000 and see what happens…

I am having the same problem but with a Kwikset lock. I can lock, unlock, set the code and get the code but not clear the code. It does VERY occasionally clear the code (1 out of every 100 tries).

Did you use the Zwave Panel to clear the code?