Schlage Z-Wave Locks

For those who have these, how does the lock and unlock feature work from HASS?

Does it report its status if manually changed?

Does it stay locked if you call it to lock and stay unlocked when unlock is called (no auto re-lock if not wanted)?

The model in question is the ‘FE599NX CAM 716 ACC 716’, not the more common dead bolts.

I have mine talking through a remote Wink hub installed at a rental property. Yes, HA shows the status (locked/unlocked) real time. Yes, it remains locked or unlocked when you set it. and yes, I am using an FE599.

I have a BE469 and an FE599. The FE599 does not report a lot. It’s kind of weird

So, it reports locked/unlocked. It will report which slot was used to unlock the door, but only if it is a new slot.

So if slot one unlocks the door, and then later the same person unlocks the door it will not report anything at all. If a different person unlocks the door that will be reported, etc.

It reports battery level.

That is about all that I have been able to get reported

For the BE469, it reports manually locked/unlocked, HA controlled, locked/unlocke with code, battery, and a few others items


What hub are you using, and would that change what is visible?

I currently have the FE469NX and it seems to work as I expect.

I’ve worried about the same thing you are talking about because they seem to be ‘old’ models. Does anyone know if they are converting all of their lines to these new looking units?

I use a USB zwave controller, no hub. Mine my 469 works just fine, it’s the FE599 that’s a bit of an odd ball.

I didn’t realize you did so much work with these, thank you!

Would Yale’s be a better option for lever style locks? I dont have deabolts and dont want to add them.

Also, there is so much conflicting and user opinion on what ZWave hub or controller does what and works best. I bought a Vera after reading many people saying stand alone hubs are much quicker…

I’m using a zwave USB stick (HUSBZB-1) and it’s been working great for me. I cannot speak to Yale, but this package should work with yale and most zwave lockes. Here is actually my lastest update for the locks packages.

So if the FE599 is unlocked by one user, then unlocked later by the same user, it doesn’t report any data? If it simply keeps the same users data on that line and updates the rest, that seems like normal operation…?

Looking at Z-Wave Alliance, it looks like many of the same features are supported by both units. How does one actually see supported functions/info in HASS or any other tools for that matter?

I have a schlage Fe599 on a rental property. It communicates to me via Wink hub to Zoom router to my home router to my HA on a PI3b+ and when a guest calls and can’t seem to punch in the codes right, I can flip the lock open on HA and within 5 seconds the guest is inside and happy.

Also, (I love redundancy), if my Wink hub or router goes down, I’m still able to control the lock via my phone app.

Also, (triple redundancy, yes - I am ex-military), the onsite condo guard shack has a manual key if we’ve lost all power (it’s on an island)

I dont know if I would call it “Normal”, but that seems to be how it works. The FE599 lock is a bit different than the BE469. It does not turn a deadbolt. I’m not sure if you’ve seen them, but when you enter the code, what it does is allows the door handle to open the door. After about 5 seconds, it “locks” again. Basically the lock feature for this lock means that the handle on the outside will move up/down, but will not engage with the lock part in the door. When the code is entered it allows the handle to engage with the Lock and open the door.

I had this with smartthings and it did report when the door was unlocked, and and which slot if you had the right driver, but I dont know if someone wrote custom code to deal with these locks as well.

Is it normal for the FE599’s to not update the UI if it was manually locked or unlocked? I have to refresh the lock entity for them to show their status correctly.

If I command anything from HA it updates the UI and status properly.

Hmm, it’s been a while since I manually locked/unlocked mine. :slight_smile:
I’ll check tonight, but I believe the answer is yes it’s normal. The 599 is definitely a bit of a pain when it comes to reporting.

What did you learn? If it’s been a while since you manually locked/unlocked them, how do you normally use them? Keycode or drag your phone out every time?

Sorry, missed this post (it was not a reply, so it did not pop up for me).

It shows up in the UI almost immediately when manually locked or unlocked. What I mean by rarely manually lock/unlock, is that my FE599 is to my garage, and I lock it when I’m gone and at night using HA, and then unlock it when I come home. Basically if I’m home and awake, the door is unlocked.

I’m wondering if anyone can provide some guidance. I have an FE599 that I had been using with Nexia for ~10 years without any issues, and moved it over to HA a few days ago. I have not had any luck at all with communication since adding it to the via the HA z-wave control panel. It doesn’t even seem to want to respond to the lock/unlock commands - and nothing ever updates in the HA GUI.

I’ve tried things I’ve seen posted in other threads, but nothing seems to be working. I’ve tried:

  1. Adding via HA z-wave control panel, and restarting HA - no luck
  2. Changing group association - no luck - no groups appear in the drop downs (and I’ve been through the additional steps to try to resolve that issue) - no luck
  3. I’ve called the zwave.update_config service, stopped HA, removed zwcfg, and restarted HA - no luck
  4. Excluded and re-included the lock after step 3 - no luck.

Any suggestions? Of the 19 z-wave devices (switches, dimmers, plug-in modules, smoke/CO detectors, a thermostat and this lock) this is the only one that I can’t seem to get to work.

Added secure? Do you have a network key set up?

Yes, network key is configured in HA (and confirmed by looking in .storage), and lock was added using add node secure.

One test was to try to add it using just “add node” - it would not enroll at all unless I used “add node secure”.

Are you enrolling with the USB removed? Are you pairing with the controller closer than it normally operates at?

I know you said you had network key set. Have you added any other devices secure? It sounds like it’s not pairing securely. When it adds, even though it’s not working, do the entities seem correct? As in you get a lock.lockname and zwave.lockname, and the few sensors as well. Alarm type, etc.

@samheidie, I am enrolling with the USB connected, and the controller in its normal location. They are less than 20 feet from each other in their normal location

@ptdalen, This is the only secure device I have. When it adds, I do get the zwave.lockname, lock.lockname, and three sensors (alarm_type, alarm_level and indicator). I did allow HA to create the key rather than specifying a key when I added the z-wave integration, but as I said I was able to confirm the key is set by looking in .storage/core.config_entries.