Schlage Z Wave Plus Lock - Solved So Far!

I am having so much trouble pairing a Schlage Z-Wave lock to my Hassio setup. The instructions I’m finding everywhere are extremely conflicting and after a couple of hours after trying to pair through the Z-Wave control panel I’ve dusted off the ole account to post instead of lurk.

I honestly have 20 bucks for the person who helps me figure this out.

I’ve tried using the red inclusion button on the back of the lock, the keypad pairing code using add node secure.

I have not tried to add a network key to the z-wave in my config.yaml yet - I figured I would ask here before I jump into that piece and also ask how / why the network key is necessary because I just want to understand as well.


Maybe you know: the lock and the Z-Wave controller needs to be within a few feet of each other while pairing.

I am about to try this you may have 20 dollars coming your way soon lol

The key is used to uniquely identify your Z-Wave hub. If you leave it blank, it will create one for you, -at least on later versions of HA. Add one if you are not sure, for example:

network_key: “0xDE, 0xA0, 0x0A, 0xB0, 0x00, 0x06, 0x07, 0x08, 0x09, 0x0A, 0x0B, 0x0C, 0x0D, 0x0E, 0x0F, 0x10”

1 Like

Ok that makes sense and helps thank you, I am running maybe one version behind the latest release

So this is what I’m seeing now, I haven’t had this with any other devices would this be correct?

Not sure what is going on, it should not be “Unknown Node”. The lock must be added using “Add node secure”.

Try again after removing the lock first. Which Z-Wave stick are you using?

The Aeotec Series 5 Stick

I may have crashed the z wave network it from all of the restarts :sweat_smile::sweat_smile:

I use a few of the same Z-Sticks, with 9 Schlage locks like yours. I have never had to start over.

I think I noticed I have Z Wave in my config file and as an integration - I’m going to remove everything out and restart it all as just an integration so it auto generates the key. That may be why my add secure wasn’t actually working

On the latest versions of HA, it takes the config from the configuration file and “imports” it, after that you can just remove the entries from the configuration files. If you start over, you may need to re-pair all your Z-Wave devices. To really reset your Z-Stick, press the reset “hole” for about 20 seconds. Beware, if you do that, you will have to reset and re-pair all your Z-Wave devices.

Luckily I only have about 10 devices now so I’ll probably just go that route as I’m adding a lot more lately - maybe a fresh start will do me well :laughing:

Yeah I thought I had done the integration so I was assuming I had a key generated already.

I reset it all - it picked up all of my devices but renamed them back to normal but I was able to pair the lock in like 2 minutes after that!

Good for you, congratulations!

1 Like

Lol I celebrated early - I moved my pi back into the game room and it shows up as unrefined/ undefined now

I’ll play around with it some more in the morning.

Will try a factory reset on the lock to re-add again!

Also the game room is like 10 ft from the lock if that

The lock will operate fine with your stick/HA at that distance. However, they will likely need to be closer for the initial pairing.

Are you able to just take off the back part to pair? I brought my pi over last time and I think that powering it off was the piece that messed it up


Ok here is what I did - especially since I was running initially from config.yaml with no key (Meaning I had no functionality to do add node secure)

  • I noticed the zwcfg file was looking a little beefy even after I tried to reset. So then I realized I didn’t finish resetting the stick because all of the nodes were still in there and half of them were recognized.

  • I tried to just delete the nodes I wanted removed from the zwcfg xml file and rebooted hassio. Didn’t work and they showed right back up.

  • Then I factory reset the z stick again and removed the integration. The zwcfg xml file was still there when I went in through Filezilla but I deleted it and restarted home assistant again and it was gone.

  • I tested adding one motion sensor before jumping into adding everything. I factory reset the motion sensor and then did regular add.

  • Hopped over the the Schlage lock, performed a factory reset on the lock (Including putting in the code to complete the reset) then used the red add button on the back of the lock after pressing add node secure within the Z Wave integration panel within home assistant.

I didn’t have to move the device close to the Pi / Z Stick. About 8-10 feet from each other but it paired in about 5 seconds and is sticking well!