The only way I have been able to call a script is by using the script id. Is there any way to use a friendly name instead? I am using HA 0.98.3 and would like to make my automations more readable.
1 Like
You could use some more readable names for scripts, for example “turn_off_lights_by_presence”.
The alias (friendly name) is mor UI-oriented, for automatons you should use the id.
2 Likes
For anything you must use the entity_id
. That is the only thing guaranteed unique, and how Home Assistant identifies entities.
2 Likes
What I found was that the ID must start with a number, but you can change it, eg:
My Script Has:
cat volup20.yaml
'20volup':
alias: VolUp20
sequence:
- data: {}
entity_id: media_player.freesoftwareservers
service: media_player.volume_up
And I can call via:
data: {}
service: script.20volup