Script.turn_on service runs all scripts, any way to disable this?


Just installed Alexa with my set up, I have a lot of scripts that do different things around the house.

The problem I’m facing is, Alexa decides to run some service called script.turn_on whenever it doesn’t know what to do,

for example, it thought I said “Turn on the freezer”, so it decided to run that generic script.turn_on script, which in turn ran all the scripts I have set up, causing havoc around the house (locks opened and closed, lights turned on and off, etc…)

This seems like a built-in script for controlling multiple scripts, is there a way to exclude scripts from that generic script? Or just disable this altogether?

Thanks in advance!

If you have a script named example there are two ways to execute it:

  - service: script.turn_on
      entity_id: script.example


  - service: script.example

Are you saying you have a script whose name is turn_on?

No, I have multiple scripts such as:


Which all get triggered when Alexa invokes this generic script.turn_on

script.turn_on is a service call, not a script. Normally you explicitly specify which script(s) the service call should turn on.

  - service: script.turn_on
        - script.example
        - script.something
        - script.other

Are you saying that if no scripts are specified that the script.turn_on service call will default to executing all scripts?


I just tested this in Developer Tools > Services and it doesn’t execute all scripts.

service: script.turn_on
data: {}

That’s what it seems to be doing, this is an example in the logbook:

See my previous post; calling the script.turn_on service call without specifying any script will not execute all scripts.

Thanks for the tip, tested this call in dev options and it does not execute all scripts indeed.

Could Alexa be calling script.turn_on on all entities then? (attached screenshot for multiple devices being triggered at the same time by this service script.turn_on

Some findings:

Currently I have my “script switches” under a room called “SYSTEM” in Alexa. Seems when I call the “Turn on the freezer” it probably guesses that this “freezer SYSTEM” needs to be turned on, so turns on all the switches in that SYSTEM room.

Is there a proper way to protect these switches from turning on from Alexa’s smart AI?

I can’t answer you latest question because I don’t have Alexa connected in the manner that you do.