Scripts are missing from Google Assistant (not cloud) after upgrading to 0.80.0?

I have a few scripts exposed to Google Assistant.
After I upgraded to 0.80.0 (and now I’m on 0.80.2) the scripts are no longer available as entities in Google Assistant.
According to the component page, scripts are still supported…
Any ideas?

Have you tried “Hey Google sync my devices”?

Yes, both this and “google_assistant.request_sync” request.
Thermostat & switches do work, only scripts aren’t.

How have you exposed them? Are you exposing them individually or by the ‘domain’? I don’t use scripts but my lights switches and scenes are all working correctly…

Did you check the docs to see if anything else changed with the new integration? There has been a huge revamp in the Google Home app… maybe that broke something on Google’s end.

Hi David,


Thermostat and switches are working, just scripts aren’t.

I did check the docs, no mention of breaking or stopping support for ‘scripts’. I changed the auth method according to the docs (0.80.0 breaking change, nothing would’ve worked otherwise)

Yeah all my entities are exposed individually as well. Weird. You should open an issue I guess.

If you are using 0.80.x, could you please try to create some script and check its visibility on Google Assistant?
Thank you!

I have the same problem.

This is actually more relevant to ‘Google Home’ app
See the issue and the “solution”:

This is not an HA issue I think, Google Home just updated their GUI and scenes/scripts just don’t appear on the front screen anymore.
Scripts aren’t missing though, they are just not shown as switches anymore. They are listed as scenes though. Go to your routines in Google Home (can now be found under settings), add/change a routine and then select that you want to change a scene (click on the configure icon next to it) - there you can selecht your HA scripts that you want to enable when calling this routine.

Thanks, Id like to be able to get those back on the front screen. I went back to 79.3 and wasnt able to add them to the front screen. I could assign the scripts to rooms and they worked when I called them, but not on that screen. I am getting a google home hub monday and wanted to have a few things i use often at a quick swipe down…

Have you tried switches? I might have to see if those show up, just create automations to call the script when the switch is flipped. My garage is still showing up, its a ‘cover’.

There is no way to add scenes/scripts to the front end of Google home anymore. So if you want it to be clickable (as it used to be), you need to add switches to HA that call the script and then use these switches in Google Home Hub.

so exactly what i mentioned will work then.

1 Like

Yes, sorry - didn’t see your 2nd post :slight_smile:

Lol no worries Im glad we can at least still get them there. I wish they showed the state though hopefully Google updates that soon. You can’t tell if there on or off. But they def put the foot in the right direction here

1 Like

Looks like I can start getting it together a little earlier:)

i am still having an issue getting scripts to show up in HA since a recent upgrade. Currently running 0.84.6 and my scripts which were previously working in Google Assistant are no longer listed at all.

anyone? I can’t get my scripts back in Google Assistant… they were all working back on 0.82.x but since going to 0.84.x (unless its a google issue that happened during the same time period) they are not in google anymore so I can’t run them at all using voice or in the GH app. any suggestions?

Dave - I seem to recall others having this problem recently… It might be a Google change… is it showing them under rooms maybe? I know I briefly had that issue. The other thing you could do is try using an input_boolean as they definitely work. Perhaps also review the cloud thread… I know there has been discussion about this but I don’t use scripts.