Scrolling a dashboard and accidentally triggering a switch

So I’m creating a dashboard for my phone…

This dasboard is longer than the screen which requires me to swipr up and down to scroll. When I do this, the button under my finger triggers. Is there any way to prevent this? Note that I still want to keep the ‘tap’ functionallity of the buttons.

I realize that I can optimize this to get it all on one screen but I would still like to know what could be done in this situation.

I just get in the habit of scrolling from a header rather than over buttons. On my iPad this problem rarely happens but it’s happened enough for me to scroll on the far edges or on a header (like scroll by touching the “Deck Porch” header instead of a button group).

I’ve intentionally broken up my dash pages into multiple pages for long ones like that for this very reason.

That would depend on which custom card you are using. The core cards have a configurable confirmation for the tap action. Which might be just as annoying.

IMO this is the best solution:

1 Like

Thanks for the info.
Looks like 3 options…

  1. Make everyting fit on the screen and continue to use the ‘tap’.

  2. Add a prompt to ‘tap’ so you don’t accidentally trigger something while scrolling.

  3. use ‘double_tap’ and set ‘tap’ to none.

I’ve had the same problems. Surely this is down to how the buttons are coded in the companion app? Other apps are designed so buttons don’t trigger when scrolling. Can this not be done the same?

Unrelated to your question but may I ask you which cards you used to build this great dashboard?