SD Card Application Class 2 ? Or an other Hardware than RBPI

Hi All,

For the second time my sd Card is DEAD.
I see in the doc than an Application Class 2 is better, never ear about that before (mine are just HC 1).
Is that really make a difference ?
Is it really reliable for long term ?

An other idea is to install HassIO on an other hardware than a raspberry, but I’m not really familiar with linux, I’ve already install and use some linux, but I can’t solve complex install problem with it.

what do you think is the best way ? I really don’t want to reinstall hassio and reconfigure stuffs every 6 month

The longest lifespan cards are Industrial ones. The next longest lifespan will be ones designed for dashcams and similar.

Everything else is about performance, not lifespan.

The best way is personal, but running on a NUC removes SD cards from the list of possible problems. Though, if you’re having to reconfigure things it suggests you’ve not been taking snapshots regularly, or you’ve not been copying them off the Pi automatically.

I have snapshot, but (last times I have do that), the secrets file was not in the snapshot, (now I have save it separately) and just after install I don’t remember all, but I have do different thinks before reinstall the snapshot.

i also have a Synology, but it seems than it is not so simple to use hassio on a Synology (mine is an old one, I think my rbpi is more powerful lol)

You think A2 card will also be dead after a few months ?

For the moment, I have no sd card in stock, so i need to buy one before the rest lol

It entirely depends on why they’re getting killed. If it’s because of the amount of data you’re logging in the database then look to excluding noisy entities you don’t care about (like sun.sun). If it’s the amount of information being logged in the log file you can limit the logging too.

You can also, with some effort, move the Docker containers to a USB attached drive, and that should largely solve your problem. So far I’ve not seen anybody document that in a step by step guide though. You’d need to to the following in the HassOS host:

  1. Attach a USB drive, format it (ext4), and mount it somewhere convenient (/mnt/)
  2. Stop all the add-ons and containers, then clone them (cd /usr/share/hassio; find . -depth -print | cpio -pdm /mnt)
  3. Update /etc/fstab to mount that drive on /usr/share/hassio - I’d recommend using the UUID
  4. Reboot and see if you got it all right :wink:

I don’t use HassOS, it’s possible some of those commands (particularly cpio) may not exist.

1 Like

I have just configure the purge, … i will made more limitation in the logs

What are you using ?

For the last two and a half years I’ve effectively been using Hassbian (it was the old All-in-one installer, but the result was the same). That’s Raspbian with Home Assistant in a Python virtual environment. My main instance is now running on a VM, again with a Python virtual environment, but my Z-Wave is still on the old instance for now.

It’s not about the purge, it’s about limiting the writes. You want to record less information, not record it then delete it.

yes, i’ve configure the purge because i have not enough free space.
but i have not thinking to limit logs for reduce writing on the cards.

i will do a lot of limitation (like sun, and my xiaomi’s temperatures devices who probalby write a lot) and keep only what i really need

I use an old SSD Drive via USB.

what have you but in your ssd drive ?

Raspbian Buster on RPI3+ and HASSIO in Docker

Is there a way to complitly disabled the recorder ?

No. You have two choices:

  1. Exclude entities or domains (you could just exclude every domain)
  2. Use an external MySQL/MariaDB/PostgreSQL database

I moved my database (only) to my Synology and my SD cards stopped dying. Hassio still runs on the Pi.

Could you explain me how did you do that ?

I suppose that you have create a share folder on the synology.
But how have you configure the new path of the database.

I installed the MariaDB package on synology then pointed home assistant to use that as the database.

i will try that, but i don’t see where in home assistant you can change the DB

You need to configure recorder to change DB

1 Like