Second network interface not working anymore

Hi. I run HAOS on an Odroid N2+
It is connected to my home network via the built-in network adapter.
To be able to connect with devices on the community network, I added a USB network adapter and gave it a fixed IP and ipv4 route in nmcli.
This worked for a while, but it doesn’t anymore.

In the Network setting of the HAOS GUI, I can see two network interfaces:


END0 is the built-in network adapter. I have no idea what ENU1U3 is.

However, if I look in nmcli, I can see multiple interfaces:

➜  ~ nmcli connection show                                       
Warning: nmcli (1.44.4) and NetworkManager (1.44.2) versions dont match. Restarting NetworkManager is advised.
NAME             UUID                                  TYPE      DEVICE 
Supervisor eth0  b1ee0c50-f24e-311e-b00a-c248f24cf368  ethernet  end0   
lo               e996f956-8ad0-4d31-84d7-42eb346fe64d  loopback  lo     
Supervisor eth0  1fa29816-9dd1-43f1-9cf2-facc36901be6  ethernet  --     
Supervisor eth1  5659b9fc-a093-364b-a48f-4d5086a7d618  ethernet  --     

The lower two both seem to have my manual settings.

What’s the cause for this and how do I fix it?

(My setup is completely up-to-date)

Same here. I just updated HA and noticed that the DHCP server stopped working. My network interface is now called “ENU1U1U1” - no idea what that is.

Same here. My ethernet is fine but both wifi adapters are disabled and it won’t let me enable them in the UI or the cli.

I changed the DHCP-config to “interface: enu1u1u1” to make it work again. Not sure how else the messed up adapters affect HA. This should definitely be looked into.