Secondary Z-Wave Controller and Schlage Lock

Tags: #<Tag:0x00007fc3ed89e690> #<Tag:0x00007fc3ed89e5a0>

I’m trying to use HASS as a secondary z-wave controller to my Qolsys IQ panel so that I can control the only z-wave device in my house, the door lock. I’m using a Zooz ZST10. I moved my Pi right next to my z-wave lock while I test things, to ensure range isn’t the issue.

I can’t seem to get it to work, it doesn’t even reflect the status of the lock, just showing as locked. I have tried using all the variations of network security keys as shown in Z-Wave PC Controller (there’s Network Key S0, Unauthenticated, Authenticated, Access, LR Authenticated, LR Access and Last Used Temp shown when I press the shield icon in the PC software), I even paired the stick to the panel and unticked all the security options except for Access as none of my previous attempts to use these keys in HASS worked.

When I test the lock in Z-Wave PC Controller, I can successfully lock and unlock, but every time I try it in HASS I get a timeout in the logs. I’ve tried this with ZWaveJS, ZWaveJS2MQTT, Open Z-Wave and even the deprecated Z-Wave integration. They all show timeout errors.

My process is this:

  • Pair to Qolsys panel via Z-Wave PC Controller
  • Test (success)
  • Plug stick into Raspberry Pi running HASS OS
  • Enter network security key into whichever z-wave integration/addon I’m trying and interview nodes, lock entity is visible
  • Test ← this is where things fail

I am fairly new to using Home Assistant, so maybe I’m doing something incorrectly? Maybe there’s another place I should be looking for the network security key? Clearly my Zooz stick works as a secondary hub, as Z-Wave PC Controller can operate my lock securely. In my current test, using ZWave2MQTT, under the secure column in the web ui, it says “no” which I’m assuming is an indication that I’m doing this wrong.

I even paired the stick to the panel and unticked all the security options except for Access as none of my previous attempts to use these keys in HASS worked.

Access is a S2 security class. Neither OZW nor node-zwave-js support S2, only S0. Did you try with S0? You would have to exclude and re-include the lock, somehow forcing S0 if the software allows it.

I have also never heard any of these software (OZW or node-zwave-js) claim to work as secondary controllers. My assumption is that they are designed to work as primary controllers, but I could be wrong. As of February (according to this comment), node-zwave-js does not support secondary controllers, and I don’t think there has been any changes since.

Thanks for the info, this is my first time messing around with Z-Wave.

As for excluding/including the lock, are you suggesting I exclude it from my Qolsys panel and then include it again while forcing S0? I wonder if that’s possible.

In terms of secondary controllers, I know of at least one user who has done it with the same hardware as me, I’ve been chatting with them on Reddit (Zooz stick and Qolsys panel), though they haven’t been able to get secure devices to work. They claim they’re able to lock their door lock, but not unlock it. I’m unable to do anything… though they could be using a non z-wave plus lock? I might get a cheap z-wave light bulb to test if I can control insecure devices.

Yes. There’s no way for node-zwave-js to communicate securely with a device using S2 security, it simply does not support any S2 functionality. Whether including the device with S0 security will change your situation, I have no idea really.

Does this mean I can’t use my lock, even if paired directly with HASS as a primary controller?

Are there any other ways I can get my lock into HASS, what if I were to use something like a SmartThings hub?

No, I didn’t say that. You can use locks with either z-wave software (OZW is deprecated, so use Z-Wave JS).

Sorry if my terminology is off, still super new to this. What I meant is if I exclude my lock from my Qolsys panel and include it directly into Z-Wave JS, will it work even if my lock is an S2 lock? I’m assuming Z-Wave JS will just use S0 by default?

Correct, because locks are backwards compatible and support both S2 and S0. Z-Wave JS only supports S0.

I see. Once the relevant PRs for this are merged, maybe I’ll be able to use Z-Wave JS as a secondary controller Implement Security S2 CC · Issue #1123 · zwave-js/node-zwave-js · GitHub

Maybe, but given the author’s statement that zwave-js does not support secondary controllers, I wouldn’t count on it.

Guess I’ll try my luck again when S2 support rolls out. I’m hoping that, even if it’s not officially part of zwave-js, that it’ll still work as a secondary since that’s part of the z-wave spec. We’ll see…

Does your lock support any other integrations…Alexa, Google, IFTTT or other cloud integrations ?

Is it still the case that the Qolsys IQ panel integration has no access to Z-Wave devices on the panel ?

So far, the Qolsys integration does not have anything other than sensors and alarm control. That said, having local control over the panel vs the old way of web scraping is a wonderul change.

As for the lock, it’s z-wave only.