Secure remote access to Home Assistant using Tor

When I try to connect to my Tor install I get Error the operation couldn’t be completed (kCFErrorDomainCFNetwork error 120.) Any ideas why? I haven’t restarted Hass so obviously when I get home that will be my first step, but I got no indication from the log or the install process I needed to do this. Everything seemed to be up and running.

@ahzazou Could you describe how you get this to work? Which version of HA do you run. I run 0.77.3 and cannot access the login screen anymore in the Red onion app either. I tested the Red onion II app and I cannot get this to load the site at all.

@henninne Red onion II app does not support editing torrc file , so to make it work , you need to disable stealth mode in TOR configuration , so it will load perfectly , just to be in safe side just be sure at least you have password for you hass instance as this address will be reachable from all Torr network.

in this section

############### This section is just for location-hidden services ###

## Once you have configured a hidden service, you can look at the
## contents of the file ".../hidden_service/hostname" for the address
## to tell people.
HiddenServiceDir /var/lib/tor/homeassistant/
HiddenServicePort 80
HiddenServiceAuthorizeClient stealth haremote1    <--remove this line to disable stealthmode

I setup HA tor onion service but get an error on logni, displayed on the page:

Logging in with Home Assistant Local .
Error: Message format incorrect: required key not provided @ data[‘client_id’]

Any help would be appreciated
pi1 b+

Possibly relates to
as TOR Browser is Firefox based

Hi! Could you be more precise on that?

How to fo that, I mean have you any links? Where can I read about hass through open vpn?

Do I understand right:
I do not need static Ip for that and even if my provider uses cgnat, I will be ok with that? And things like google assistant and ios tracker will work just fine?

You don’t need a static IP - you can use a free dyndns service.

However you will need the cloud service for home assistant for google assistant to work. I pay 5 dollars a month for it

Exactly the same error here… And additional this similar one:

Logging in with Home Assistant Local .
Error: Message format incorrect: required key not provided @ data[‘redirect_uri’]

Already set the base_url in configuration.yaml to my .onion domain, but that doesn’t help and is not needed as far as I have understood.

So could anybody help with this?

Pretty sure this is a Firefox issue:

So TOR is not going to work either.
I managed to troubleshoot my port forwarding issues and so moved away from using .onion service

Seems it has been fixed here:

Hope it’s fixed in the next update

1 Like

Which Android Tor browser do you recommend?

With Tor browser reach my hass instance but I receive this error

Logging in with Home Assistant Local.
Error: Message format incorrect: required key not provided @ data[‘client_id’]

Followed the instructions and i have the same config as this one.
I can open the 8123:80 just fine and everything works well but accesing Node Red from the menu it navigates me to

Any hints what might be the issue?


I have a Synology NAS at home. I run a VPN server on that. I connect the client to my VPN from anywere. (no ports open)
And I can control everything.
So you’ll need a device to run a server and a OpenVPN client. A lot of routers can be used as a OpenVPN server.

I thought that to use VPN you need to open at least one port in the router

My mistake, you right.

Any update for iPhone settings? Using onion Browser and I can get to login page of without any problems, but when i type login and pass i am getting just the logo and “retry” button. I just tried Red Onion II browser and this is getting only to “initilasing” when accesing

I am running HassOS 4.16 with TOR-addon 2.4.1 and just installed recent version 2.7.1 of ios Onion browser.
Unfortunately behaviour is still exactly the same as Tom described: successful connection to ha-instance, no prob to log in but then retry button appears (pressing it leads back to login).

Has someone made any progress on this topic?
Thx in advance for any hint on how to overcome this problem!

Is that tor support only for web GUI (with browser) or if you direct all the Home Assistant for Android through Orbot, then i can use all the sensors of all persons phones with reasonable lag without having all neccessary ports open by ISP?

Hey guys! New to Tor, setting up remote access for homeassistant was my reason to try it. I got what is possibly a newbie question - where exactly can I see the ‘client name’ needed for stealth authentication? Or where do I set it on the client? I got it running without stealth (using Tor browser on Android), but when I try to set up stealth authorization (inputting .onion address and cookie as custom HidServAuth string in Orbot settings), it doesn’t seem to work. I just used a random client name when generating the cookie in HA, thought it was like a label, but now I think it might actually mean something. Any help appreciated!