Sending http post to hassio via ifttt not working


i am currently trying to send an http post to my hassio via IFTTT, which I am calling via my ghome.

I already have configured http post for my flic buttons as well as tasker and it works flawlessly, but for a strange reason it does not work via ifttt. Here is what I got:


any idea what I might be doing wrong?

I suppose there is a script.toggle service, but I’m wondering why you’re using that instead of script.turn_on, or even script.MYSCRIPT (i.e., …/api/services/script/MYSCRIPT.) If you use this latter form then you don’t need to specify any body.

Regarding the specifics of your IFTTT webrequest, I don’t see anything obviously wrong. FWIW, error 400 is “bad request”, which I think usually means the URL or body is malformed.

I just tried invoking one of my scripts both ways (script/SCRIPTNAME, and script/toggle with the body specifying ‘{“entity_id”:“script.SCRIPTNAME”}’) using curl, and both ways worked. So I guess the fact that you’re using script/toggle isn’t an issue.

So, not sure what’s wrong with your IFTTT webrequest. Unless did you maybe spell the name of the script wrong???

Yeah, what @pnbruckner said, specially check for unnecessary capitalizations in the entity name

before using toggle, i tried turn_on intuitively. when that didn’t work I just copy pasted everything from tasker and from my flic configuration, where it is working.

but ifttt returns that weird error and really do not understand why. is there something else I need to configure within hassio, so that ifttt can communicate with it? If yes, it would surprise me, because I did not have to do that for tasker or flic. After all, I am just asking ifttt to send a command to HASS via the hass api, which is apparently working, but not for ifttt…

ok, nevermind, I solved it by using my non-existing artistic skills:
the quote signs were different from each other. if you look at the quotes within the body code, you will find that the last quotes differ from the other ones, as those are vertical and the others diagonal.

what is this BS? everytime you think you have seen it all, you get surprised.

long story short: problem solved by retyping quotation marks, which were “buggy” due to copy pasting…


Thank you for posting the solution! I was on 4-hour nightmare trying to figure out what was wrong with my applet, until I read tour post!

1 Like