Sengled wifi bulb control


I’ve bought a Sengled WIFI bulb which doesn’t require any hub to be connected.
I’m now struggling second week to have it connected to HA.
HA doesn’t perform auto discovery on it and there is no Sengled platform in Light component.
On/off is just enough for me : )

ANY ideas and hints or workarounds appreciated. I’m a little bit loosing hope as for now.

Thanks for everything!

1 Like

If you want to get this to work with HA, you’ll need to get a hub that is supported by HA like Smartthings. I have a bunch of the Sengled Classic Element bulbs (Zigbee version) and they work great with HA, but I use it with Smartthings.

The only other option is to use it only with Alexa or GH, and but HA on the back burner until the HA devs decide to create a light component for it.

This appears to be a Wi-Fi bulb though. Somebody with one will need to figure out the protocol & how it operates.

That’s what components are for, and the protocol (Zigbee, Zwave, wifi, wtc) doesn’t really matter. If the company claims that there is no need for a hub, then it means that the device is most likely talking directly to the cloud. What the HA components do, is also talk to the same cloud server and relay commands to/from the bulb. This is what GH and Alexa are doing.

The only way to bypass this, is to find an exploit within the communications between the bulb and its cloud server, and create some kind of man in the middle server to intercept that communication. It can get very complicated, especially if the communication is encrypted, and not something that a novice can do.

What I would suggest (if you don’t want to buy a hub) is to make a request for a new feature to the HA devs. But you gotta remember, this is a two way street. Sengled has to make their APIs public or available to HA for this to work. Since both Alexa and GH can control this bulb without the need for a hub suggests that Sengled do make their APIs available to some degree.

The other option is to go through the list of supported components in HA, and find something that is supported like Tuya bulbs, at least until your bulbs are supported by HA.

1 Like

One last thing:

In the future, when you look for smart devices (especially lights) that don’t need hubs for them to work, I think its safe to say that they WILL NOT work with HA, unless its explicitly listed as one of HAs supported devices. And even it is listed, make absolutely sure that HA can work with it by asking if others have tried it, and what it takes to get it working.

Again, hubless devices are hubless because they are hard coded to talk to their cloud server and ONLY their cloud server, by using your home wifi internet connection to receive/send commands to the cloud

1 Like

I have created this HA Addon for the Sengled Bulbs. It might help.


Tried manual install and failed. Used HACS and everything works like a charm! Great job, You should reccomend this to the next update as a component.

This component still needs a lot of clean up done before that can happen.

Thank you for investing time to make this great Addon…for some reason when I attempt to add it by copying the github address, I get an error in Home Assistant that says: “Invalid Add On repository”. Am I doing something wrong? I’m in Supervisor tab, Add On Store tab and clicked the 3 dots and chose Repository and then pasted the github address. Any advice?

Installation (HACS) - Highly Recommended

Have HACS installed, this will allow you to easily update
Add as a custom repository as Type: Integration
Click install under "Sengled Bulb Integration" in the Integration tab
Restart HA

Thanks Francis for the quick reply!..that was the instructions I was following when I got the error message. That’s why I was asking if I was accessing HACS incorrectly. I went to Supervisor tab, Add-On Store tab and clicked the 3 dots and chose Repository and then pasted the github address. If there is some other process for installing HACS and accessing this, can you share the more detailed procedure for adding HACS, please?

Thanks a lot! I just integrated this solution and worked with two bulbs that I have. Very much appreciate!

1 Like

@cfurini What version of HA are you running? This issue has been raised against 2023.6.0 so I’m wondering if anyone else is having the same problem or not. Thanks.

I’m running the 2023.6.1 at the moment

Thanks. And it’s definitely working OK with the wifi bulbs? If so, I’ll go ahead and go the 2023.6.x upgrade.

Yes - it is working beautifully at the 2023.6.1

Where do you get the sengledpai? I’m assuming the user/pass is what you use when installing the Sengled Home app? Thanks!!

username: [email protected]
password: sengledPassword
country: us
wifi: true

Did you follow the install instructions in the link here: [(Sengled wifi bulb control - #6 by allenfarmer1) ? The username and password are the ones you created in the app, yes.

Hi, I followed these instructions and I now see my four Sengled bulbs in Settings->Devices & Services->Entities, and I can turn them on and off from that page. I even added them to one of my dashboards. But when I try to add them to an existing scene, I don’t see those bulbs as an option.

(I’m assuming that’s because they are listed as entities and not as devices, but I could be wrong.)

Is there anything else I need to do to add those bulbs to a scene?