Sensibo API seemed to be broken for Home Assistant

For 2 - 3 (Sep. 2017) Weeks now Sensibo component won’t load any more.
It throws the following error when it starts

2017-10-13 18:00:38 ERROR (MainThread) [homeassistant.components.climate] Error while setting up platform sensibo
Traceback (most recent call last):
File “/usr/src/app/homeassistant/helpers/”, line 164, in _async_setup_platform
SLOW_SETUP_MAX_WAIT, loop=self.hass.loop)
File “/usr/local/lib/python3.6/asyncio/”, line 358, in wait_for
return fut.result()
File “/usr/local/lib/python3.6/asyncio/”, line 245, in result
raise self._exception
File “/usr/local/lib/python3.6/asyncio/”, line 180, in _step
result = coro.send(None)
File “/usr/src/app/homeassistant/components/climate/”, line 55, in async_setup_platform
devices.append(SensiboClimate(client, dev))
File “/usr/src/app/homeassistant/components/climate/”, line 76, in init
File “/usr/src/app/homeassistant/components/climate/”, line 87, in _do_update
temperature_unit_key = self._ac_states[‘temperatureUnit’]
KeyError: ‘temperatureUnit’

I bought my Sensibo for a couple of weeks ago and it worked just fine for a few days. Now HA can’t change the temperature anymore. Error log doesn’t show anything, but haven’t tried to debug yet.

If I change the temperature with the Sensibo app, HA updates with the correct temperature, so the API works somehow. Still the same issue from 0.56 to 0.57.

It seems like it’s only a problem with the temperature parameter.

Upgrading to hassio 0.57.2 did not solve the problem.

Edit: 5 hours later it seems to be working again - maybe 0.57.2 was the solution for this issue ??

I experience the same behavior again @ 0.58.1, any ideas ?
I’ve opened the following issue in github

Hi, I’m trying to install two sensibo in HA but as soon as I add the code in configuration.yaml all my other climate component just disapear and nothing showup for sensibo.

in configuration.yaml I have added:


  • platform: sinope
    username: !secret climate_username
    password: !secret climate_password
    gateway: !secret climate_gateway
    scan_interval: 60
  • platform: sensibo
    api_key: Dcm8lOhaw2yXH
    • salon
    • chambres

as soon as I restart HA all the climate component stop working. There is nothing in the log