Sensibo metrics only update after HASS restart, errors

Hi all,

I’ve found a few folks with similar issues but nothing with a solution that has worked yet.

I’m getting these errors in my HASS log and I don’t know if this is why Sensibo metrics only update/poll on server restart.

`Logger: homeassistant.components.climate
Source: components/sensibo/
Integration: Climate ([documentation](, [issues](
First occurred: 12:29:04 PM (2 occurrences)
Last logged: 12:29:04 PM

* Error adding entities for domain climate with platform sensibo
* Error while setting up sensibo platform for climate

Traceback (most recent call last): File "/usr/src/homeassistant/homeassistant/helpers/", line 382, in async_add_entities await asyncio.gather(*tasks) File "/usr/src/homeassistant/homeassistant/helpers/", line 607, in _async_add_entity await entity.add_to_platform_finish() File "/usr/src/homeassistant/homeassistant/helpers/", line 715, in add_to_platform_finish self.async_write_ha_state() File "/usr/src/homeassistant/homeassistant/helpers/", line 486, in async_write_ha_state self._async_write_ha_state() File "/usr/src/homeassistant/homeassistant/helpers/", line 521, in _async_write_ha_state attr.update(self.state_attributes or {}) File "/usr/src/homeassistant/homeassistant/components/climate/", line 261, in state_attributes self.current_temperature, File "/usr/src/homeassistant/homeassistant/components/sensibo/", line 247, in current_temperature self._measurements["temperature"], TEMP_CELSIUS, self.temperature_unit KeyError: 'temperature'`

The integration works, as in I can toggle the A/C on/off but metrics are not automatically updated. I’ve tried scan_interval as well.

Here’s my configuration.yaml.

   - platform: sensibo
     api_key: <sanitized>

  - sensor:
      - name: Office Humidity (Sensibo)
        state: "{{ state_attr('', 'current_humidity') }}"
        unit_of_measurement: '%'
        icon: mdi:water-percent
      - name: Office Temperature (Sensibo)
        state: "{{ state_attr('', 'current_temperature') }}"
        unit_of_measurement: '°F'
        icon: mdi:thermometer`

Any ideas?


I am having the same issue :confused:
Does anyone found a solution yet ?

Edit: I opened an issue: Sensibo integration seems broken · Issue #61710 · home-assistant/core · GitHub