Sensor SSID iOS Iphone

Hello everybody,
I have two iPhones with HA apps that don’t update their SSID sensors. I checked in the app and everything is enabled, but not even the SSID sensor consulted by the app (not in HA) the status is always “not connect”
what can i check?

What’s your location permission for the app currently set to? This requires both ‘always’ and ‘precise’ location permission enabled.

I actually set “never” because I didn’t want to use geolocation. is there a way to use SSID without geolocation or block only GPS geolocation?


Nope, iOS doesn’t allow access without it. You can turn off the location being sent to the server in the server’s settings (location privacy) if you want to be sure it isn’t set up. Accessing SSID/BSSID information can effectively pinpoint your location, so it’s considered precise location information.

ok thanks for the explanation.
Eh ere do i turn off location privacy? in the app or in HA?
disabling the latter, however, does it still detect the radius of the house or disability too?

You’ll need to give Home Assistant permission in the system Settings app > Privacy > Location, both precise & always.

You can prevent latitude/longitude from going up to the server in the app Settings > [Server] (at the top) > Location privacy. You can either send up the zone name of the zone you are currently in, or don’t send anything.