Sensor unavailable with mqtt integration (Smoke detector)

The problem is that in my dashboard the status of my smoke detector is unavailable.

In mqtt configuration yaml file I have setup the configuration as follows. As a Smoke detector in normal circumstance is not going off that often :wink: I look at the LWT of my Sonoff bridge. If I look with my mqtt client I see that the LWT is Online. Any idea what I’m doing wrong?

- name: "Smoke Eathon"
    unique_id: "smoke_eathon_room"
    state_topic: "tele/sonoffbridge1st/RESULT"
        - topic: "tele/sonoffbridge1st/LWT"
          value_template: "{{ value }}"
          payload_available: "Online"
          payload_not_available: "Offline"
    value_template: "{{value_json.RfReceived.Data}}"
    off_delay: 5
    qos: 1
    payload_on: "648E86"
    device_class: smoke

Have you changed it over to the new mqtt: rather than just the old binary_sensor: setting in config.yaml?

yes I have done that.

Check it hasn’t renamed the new mqtt id as “smoke_eathon_room_2” in settings/entities

restart mqtt
You can also try reloading the broker if it’s not renamed it.