Sensors don't change state after update 0.90

Hi there,

after updating to 0.90 i noticed my automation didn’t worked anymore (it always did).

when i open garage door, the light in the garage will go on. after closing the door the light will stay on for 5 minutes and the go out.

the automation includes 2 xiaomi door sensors, wich change state (true/false) in my zigbee2mqtt add-on but they don’t change state (on/off) in the dev/state page. they are visible in the state off, but won’t change to on.

i tried to remove the sensors in settings -> integration -> mqtt: configuration.yaml page, but when i restart HA the re-appear.

also tried to re-install zigbee2mqtt and reconnected the sensors.

any ideas?

I would focus on this aspect first.

Use an MQTT client (such as MQTT Explorer, MQTT.fx, mosquitto_sub, etc) to confirm the two sensor topics are receiving valid payloads. When you open/close the garage door, the payloads should change accordingly.

This implies Home Assistant has a good connection with the MQTT broker because the discovery process is detecting the sensor’s auto-discovery topics (and registering the newly discovered sensors).

Thanks for your reply!

Now you mentioned MQTT, i looked into my mosquitto add on ( also updated it) and i saw that my client id wasn’t available.

also my sonoff isn’t accesible trough it’s ip-adress, where before it was @, now the page times out. I checked my router for the right adress…

this is what i got:

553177595: |-- mosquitto_auth_acl_check(…, client id not available, MichaelDuijkers, homeassistant/#, MOSQ_ACL_WRITE) 1553177595: |-- aclcheck(MichaelDuijkers, homeassistant/#, 4) CACHEDAUTH: 0 1553177599: |-- mosquitto_auth_acl_check(…, client id not available, MichaelDuijkers, stat/sonoff/POWER, MOSQ_ACL_WRITE) 1553177599: |-- url= 1553177599: |-- data=username=MichaelDuijkers&password=&topic=&acc=-1&clientid= 1553177599: |-- aclcheck(MichaelDuijkers, stat/sonoff/POWER, 4) SUPERUSER=Y by http 1553177599: |-- Cached [3E3529B26027EC8A901655B319F712F0F5429FBE] for (client id not available,MichaelDuijkers,4)

when i turn on the light on/off in home assistant (with MQTT), it works fine…but anything else, don’t know…

hope you, or anyone else can help me out.


There’s a lot more that’s gone wrong here than just the Home Assistant upgrade. You’ll need to sort out your networking problems first.