Sensors not reporting to homeassistant

Hello, I am having some issues with HASSIO install on Pi.

It was working fine for last 2 months but started having issues.
Some of the issues are as follows,

(1) Aqara motion / Door / Temperature sensors are reporting intermittently. When I check ‘Xiaomi Home’ app I can all of the sensors are regularly updating but hassio don’t get the update.

(2) Kasa Tp-Link switches have become orphaned enities even though they are live and I can use native app to interact with them.

Any help would be highly apprecited.


The name hassio was deprecated 6 months ago. It was replaced by Home Assistant OS.

Which integration are you using to communicate with the Aqara devices?

The TP-Link integration was negatively affected by a recent firmware update supplied by the manufacturer.

1 Like

Thanks for response @123

I am actually using ’ Home Assistant 0.118.4’ sorry for confusion.

i will reach out to Tp-Link to rollback.
Sorry i just checked and i can confirm i am still on old firmware i.e. 1.5.8 (UK). Do you think I will be impacted by something else.

I am using ’ Xiaomi Gateway (Aqara)’ to communicate to Aqara devices. This was perfectly working fine but broke for some reasons.

hi, i just tried deleting home-assistant_v2. db file as well but to no avail.
please see screenshots of the sensor. Xiaomi home is reporting motion but homeassistant does not.

I assume all the TP-Link devices and the Xiaomi Gateway communicate with Home Assistant via Wi-Fi.

  • If you can control the TP-Link devices with the Kasa app and you can see sensor updates in the Xiaomi app, that means your phone is communicating with them via Wi-Fi. It implies the switches and gateway are connected to Wi-Fi and are functioning normally.
  • We know Home Assistant is connected to Wi-Fi because you’re accessing it via your phone.
  • The missing link is the connection between Home Assistant and the switches and gateway.

Have you checked Home Assistant’s Log for error messages?

yes exactly this i was thinking all devices are communicating to internet,
but i dont have anything in logs which suggests these issues. Please see the following.

Till last night i was able to get battery states from sensors and also was able to turn on / off gateway light, today this has all stopped.

I was able to work KASA by removing the integration and adding it back, not sure if I do same to Aqara gateway i have to redo all device / entity names etc :frowning_face:

after removing xiaomi integration and adding it back. I can see some sensors randomly reporting again.
Get different error in logs now,

i am using android and entered the same key multiple times but still the same issue.

@123 thanks i have resolved the issue.

eventhough it appears stupid but a restart to network equipment did resolve the issue. I am using Deco M5 which was rock solid with no issues :frowning_face:

before restarting network equipment i had to delete Xiaomi Aqara integration but it did not solved the problem

Possibility, but based on the warning messages I see in your Log, you have many other issues to address as well (that are unrelated to Wi-Fi).

Good luck.