Sensors not working

I did a clean install of the All In One Installer to get zwave working. After reinstalling, none of my sensors seem to be working (I don’t see them on my dashboard.) I’ve tried putting them directly in my config and importing them via directory list. Here’s the speedtest:

platform: speedtest
  - ping
  - download
  - upload

Imported into my config via sensor: !include_dir_list sensor. I am starting hass straight from the CLI instead of via service- the service was just silently failing for me, nothing in the logs, nothing running.

What are my next steps in troubleshooting this? I don’t see anything pertinent in my logs.


Try running hass --script check_config and see if it gives you any errors about the syntax of your configuration.

If you comment out sensor: !include_dir_list sensor and put this directly in your configuration.yaml file and restart, do you see the sensors?

@justyns, thanks, I’ll try that when I get home.

@rpitera- no, I pasted that speedtest chunk into configuration (after nesting it under a sensor and it still didn’t work. This exact syntax was working before I did the clean install, so I was hoping something changed in a new version of HASS that I didn’t know about.

Could you post your sensor section as you had it for the test? Just want to rule some things out.

Sure, here’s my configuration.yaml:

  # Name of the location where Home Assistant is running
  name: Home
  # Location required to calculate the time the sun rises and sets
  latitude: REDACTED
  longitude: REDACTED
  # Impacts weather/sunrise data
  elevation: 4280
  # metric for Metric, imperial for Imperial
  unit_system: imperial
  # Pick yours from here:
  time_zone: America/Denver

# Show links to resources in log and frontend
# introduction:

# Enables the frontend

  # Uncomment this to add a password (recommended!)
  api_password: REDACTED

# Checks for available updates

# Discover some devices automatically

# Allows you to issue voice commands from the frontend in enabled browsers

# Enables support for tracking state changes over time.

# View all events in a logbook

# Track the sun

  platform: nest

  username: REDACTED
  password: REDACTED

sensor: !include_dir_list sensors

automation: !include_dir_list automation

And inside /sensors:


platform: nest
  - temperature
  - humidity
  - target


platform: speedtest
  - ping
  - download
  - upload


platform: time_date
- 'time'
- 'date'
- 'date_time'
- 'time_date'
- 'time_utc'
- 'beat'


platform: yweather
woeid: 12792944
forecast: 3
 - weather
 - temp_min
 - temp_max

hmmm don’t you need

- platform: nest


@keithh666 I don’t think so. I’m awful at YAML, but looking at the example configs (eg Teagan’s) this looked like the way most people are doing this.

Not really, you’re looking at a small sample. People do them all kinds of ways. I have all my sensors in one file called sensors.yaml I had problems in the past trying to use dir_list and dir_list_merge so I stopped using them for a while until I better understood them.

I think the problem is that you do need to specify the platform if you have them all in one file like I do, but when you’re using the it the way you have it set up now, you should remove the platform: line from each one and since you correctly named the yaml file the same as your platform, you should be using dir_named instead.

If my understanding is correct, this uses the filename as the platform and the contents of the file as the platform’s settings or arguments.

1 Like

@rpitera I found examples that do what I was doing, but the vast majority of them were like you said. I switched to dir_list_merge and changed each sensor to be the list syntax (- platform: ...) and it works! I’m not sure what specifically was causing the issue but I’m happy to be working again. Thanks for the help!