Serious z-wave problems


#1

Hi
I have been running Home Assistant for several months now, and I’m very pleased! But:
I have some serious z-wave problems.

Sometimes, when I restart hassio, it starts, but there are very few devices that show up. The rest are logged as unknown.
Sometimes z-wave network doesn’t start at all.
Sometimes it starts and everything looks fine from the beginning, but:

Z-wave is extremely slow for some devices, but not for all.
Yesterday, turning on some LEDs via a qubino dimmer took several minutes (at least that’s what it seemed like).
Today, the same LEDs react immediately.
Starting the z-wave network also takes a long time, 15-20 minutes.
I have about 50 devices. Almost all are directly “visible” from the controller.
The controller is placed in my basement and is at the center of my house.
I’ve tried connecting the controller, Aeotec stick5, direcly to my computer (Intel i5 NUC running Debian 9 stretch) as well as via a 1 meter USB extension cord.
The stick is the only thing that I know that is operating at the z-wave frequency.
I’ve tested with two different Aeotec sticks.
I’ve tried testing and healing the network.
Please, I need some advice so I can start searching for a solution!
Helge


#2

Have you added any new devices lately?


#3

Try connecting directly to the USB port. Ive had issues with these extension cables before.


#4

How many of your zwave devices are powered vs. battery operated? The ZWave protocol uses powered devices to create a mesh network for better and more reliable covered.


#5

I had it connected directly up until a few days ago when I tried it on an extension cable. The behavoiur is the same. I’ve tried two extension cables, so I think (at least hope) that they’re ok.


#6

I have about 20 battery operated, mostly wall controllers and PIR sensors. They seem to behave ok.
I have run the ozw log file through the openzwave scan log file utility. It says, among other things, that I have «RF-related issues», «wireless interference or collisions on the z-wave network».
But I can’t find any source of interference.


#7

My guess is that a few powered zwave devices would help the network.


#8

Also keep in mind it takes a few min after you start until the zwave network is ready. For my system with ~50 devices, it takes 3-5 min.


#9

This is a problem that has surfaced recently for me too. Out of 30+ z-wave nodes, I only have 4 (including the Aeon z-stick controller itself) recognized by hass.io. I have a spare z-stick, to which I have restored the z-wave backup from my main z-stick. Same problem, only 4 nodes show up.


#10

I’m still digging for answers.
Looking at my ozw_log.txt, I find things like:

2018-12-30 20:37:54.770 Info, contrlr, There is a SUC ID Server (SIS) in this network.
2018-12-30 20:37:54.770 Info, contrlr, The PC controller is an inclusion static update controller (SUC) which is using a Home ID from another network and was the original primary before the SIS was added.

When I started using this aeotec stick, I also had a Fibaro HC2 controller. Has the stick added itself as a secondary controller of some kind?
The HC2 is no longer here.
Could that cause the kind of problems that I’m having?


#11

Hi.
I had similar problems a few days ago,
All or some of my zwave device were not showing after a restart.

I commented out # device_config: !include zwave_device_config.yaml
in my config and never had this problem again.


#12

I don’t have this at all. Where should it be? In configuration.yaml?
I’m on version 84.6


#13

You wouldn’t necessarily have to have it. It’s an optional entry in the config under “zwave:”


#14

Yes, this is absolutely the issue. I have no idea how to get out of it, but it’s clearly trying to deal with another controller in the network.

Maybe there’s a z-wave guru around here who can help you. Do you still have the HC2 to properly exclude it?


#15

If you have a secondary controller configured and not present, it’s gonna mess with your mesh. Sounds like you promoted Home Assistant to primary via some other controller?

I’m not too familiar with secondary controllers in OZW, but do you see anything in the Z-Wave Node Management panel regarding a secondary one?


#16

That´s what I was afraid of.
I haven´t promoted the new controller or anything. That is something that HC2 and Aeotec stick must have figured out (in some kind of fight?) on their own…
Unfortunately, I have sold the HC2, and it´s very far away by now.

I can´t find any trace of it in any control panel (hassio or aeotec stick tools).

I do, however, have another factory clean aeotec stick.
Is the “best” thing to do simply to remove the old stick, reset everything hassio knows about zwave and start over with the new one?
Soon, it´s weekend, and the weather forecast is bad. So maybe recreating my zwave system is a good way to spend it.
At least if you think there´s fair chance of success?


#17

Really hard to tell. But the weather gods are with you apparently…

But if you decide to reset the network, make sure you do it properly. I would:

  1. Make sure I have all removal procedures documented for all devices and check if you have special node configurations.
  2. Remove the nodes one by one in the Z-Wave Network Management. (Makes sure that they are not associated with a gateway so they can easily be included again).
  3. Pull out the Aeotec
  4. Delete the zwcfg_xxx.xml, pyozw.sqlite, OZW_log.txt, zwscene.xml and options.xml
  5. Make sure you don’t have Z-Wave configuration that stops rebooting. (Remove from configuration.yaml or the integrations panel)
  6. Check core.config_entries and core.device_registry and core.restore_state if there are any zwave components left. If so, clean the out.
  7. Reset the Aeotec stick and plug it in again. Reboot HA.

Start rebuilding your Z-Wave network and make sure you run a heal network with it. Also keep an eye on the OZW_log.txt if you start getting errors or warnings.

  • Set Node Config options.
  • Some items as you know, needs to be woken up before they get properly configured.
  • Make sure you don’t have unnecessary polling setup

Once this is done, let the network rest for some time. (So all battery devices get a chance to update). Then run a heal network again.


#18

Thanks for the tips. i’ll give it a try!
Where do I find the core.config_entries etc. that you’re mentioning?
I was planning to just factory reset the devices and add them to the new controller stick one by one, starting with some of the mains powered devices.
Is that a bad idea? (I have all the necessary documentation readily available)
Edit: I found the core.xxx files!


#19

Each device is paired. So if you factory reset only one of them, the other one will wonder where it went… I would reset all of it. If you want to pair with a new stick, it’s up to you. Dunno if there is any difference between using a new or the old one…


#20

Now, I’m in the process of moving devices to a new stick.
Just a handful devices have been moved, but I’m already seeing that the system is more stable, which is very nice.
But: It is slow!
Lights take 5-10 seconds to turn on, usually faster to turn off, when I use the HA/Lovelace interface.
I’ve tested with 3 different switch types: Merten double-pole, qubino flush 2 relays and Everspring AN179. They are all very slow. They are all within 5 meters from the stick.
I also have some wall controllers (popp wallc) associated with the switches. When I use that, the lights respond within <= 1 second.
Strange, or what? Is it a Intel NUC/Debian/Controller problem? (I’ve tested with two different sticks.)