Seriously cannot get location tracking working on iOS

So, ive tried everything. It has worked before or used to work and then stopped working.
All the notification and location permissions are correct, and yet the location just does not update.

The phone has a permanent connection to HA via a Cloudflare tunnel, using the external connection setting and URL defined for the tunnel and HA is accessible remotely, but still no location update.

What’s next? I’m honestly not sure where to go from here.

Any ideas?

iPhone …beep… :slight_smile:
Try to manualy update the location from within the app settings but I guess that works
And my only (!) solution so far was to re-install the app and with that, select location to be updated always with all the trimmings

Yup nope, that didn’t work either :frowning:

The manual update, the reïnstall or both?

Both, I tried the manual update after the reinstall.

It’s weird because when I check the entity, it says updated 35mins ago and seems to be “Updating” the location but the location just does not change.

It’s almost like it knows when the location changes and updates, but doesnt update the correct location? Because the location says its changed state every time the phone leaves home, but its not the correct location, it just remains at the same address the whole time.


Very odd, esp. the manual update. Are other sensors related to the companion app updating? e.g battery %, charging, etc.?

I think so, I can double check that the data is accurate and confirm but yea it looks like all other sensor data is there.

One thing I have noticed is the phone storage is FULL. Like completely full and homeassistant also reports its storage as full. Wonder if this could be impacting it somehow?

Can’t tell but there may be adverse effects to that…