Service notify.mobile_app missing


Somehow my service notify.mobile_app_x (x = any registered device) is missing. I’ve tried everything that I can find online, but nothing seems to help.

If I go into services and searches for «notify.», none of the mobile_app's shows up.


I’ve tried to restart HA (including a reboot of the server) and reload the mobile_app integration, but the log shows that the HA only reloads the following:

2022-08-21 16:31:40.524 INFO (MainThread) [homeassistant.components.sensor] Setting up sensor.mobile_app
2022-08-21 16:31:40.525 INFO (MainThread) [homeassistant.components.binary_sensor] Setting up binary_sensor.mobile_app
2022-08-21 16:31:40.525 INFO (MainThread) [homeassistant.components.device_tracker] Setting up device_tracker.mobile_app
  • sensor.mobile_app
  • binary_sensor.mobile_app
  • device_tracker.mobile_app

Any idea what can be wrong and how I can solve this?

I’m using the official HA Companion App from the Google Play Store. It’s installed on 4 different devices.

Thanks for all your help!

There was a fix for this in the latest HA core update. Are you up to date?

1 Like

Oh, I’m on 2022.8.3. Updating to 6 now :slight_smile: Hope it solves it.


1 Like

I’m experiencing this issue right now. Latest update 2022.9.2

Same here also with the 2022.9.3 it is gone

You should make an issue at Github; I can’t find any new issues on it since august (which is closed): Issues · home-assistant/core · GitHub

1 Like

Already fixed. iOS16 hides the names of devices for security reasons. You need to go into the HA app on iphone and put the device name into the app to fix it.

1 Like