No notifications available in iOS 16 beta

In iOS 16 it is not longer possible to send Home Assistant notifications to my device.

2 Likes

The app devs hang out in this Discord support channel: Home Assistant

@zacwest posted this in Discord, which fixed it for me.

oh this makes sense. iOS 16 has a new privacy feature - it lies about the device name!
you’ll need to manually set the device name in the server’s settings (in the app) to what you want, for now, on iOS 16
it’s possible we’ll be able to ask apple for permission to get the real device name once again, but for now the app is told basically “the device was renamed from Bob’s iPhone to iPhone” so we pass that along to the notify service

13 Likes

thanks for this. Mine hasn’t worked for 2 days now until I saw the above post. Works now!

For posterity, I had to:

  • Go into Settings in the mobile app
  • Select “Companion App” from the menu
  • Tap on my server at the top of the screen
  • Change “Device Name” to what it used to be (i.e., notify.mobile_app_DEVICE_NAME_HERE)
  • Exit settings
  • Force-close and restart the mobile app

I was then able to go into Developer Tools → Services and confirm the expected notification service was available.

13 Likes

This only seems to rename the notify service. If you want all your sensors/entities to be renamed as well, you need to delete the config entry from Settings → Devices & Services → Mobile App.
After restarting the app on your phone, it will automatically be created again, and all sensors/entities will have the new device name.

1 Like

just for reference an official troubleshooting step was also added here: https://companion.home-assistant.io/docs/troubleshooting/faqs/#ios-16-device-name-missing-from-notify-service-andor-entities

1 Like

My alerts stopped as well but very confused over what I change where to make it work…

On the iPhone I opened the app itself > App Configuration, I clicked at the top entry (Above Add server), > Device name was just a grey entry with ‘iPhone’ so changed it to “notify.mobile_app_calz_iphone”, closed restarted etc but nothing worked.

I poked around my automations and the service seems to have changed from
service: notify.mobile_app_calz_iphone
to
service: notify.mobile_app_notify_mobile_app_calz_iphone

What am I doing wrong or have I got to go through all automations and change it?

Think I worked it out by reading a post on the discord channel, set my device name to “calz_iphone”, restarted app and seem to be getting alerts back, confusing info above that says you need to change it to “notify.mobile_app_calz_iphone”

Is there anything else we can try to get notifications working on iOS16? I have been through all these steps and still no notification is received.

On the companion app under Notifications i can see the rate limits going down from 500. I have tried resetting the push ID as well.

A lot of the confusion might be around when it was setup and how etc, some people say add mobile_app some note some notify. etc It might be more useful if the devs documented where to lookup your specific details, then it’s unique to them and should work. It was Apple that made the change to ‘anonymise’ the name of the phone from the app so I went into settings > general > about on my phone and where it says ‘name’ in my instance ‘Calz_iPhone’ I assumed it was this before the update and entered it into the app as this and now seems to work again.

Thanks for this Tip, I don’t think I would have known where to look. Appreciate it!

The notifications are not working sending to a Mac with the companion app installed also.

It cant be just an iOS 16 issues.

Found it!!!

So it would seem in my personal focus profile , Home Assistant was not an enabled app.


1 Like

Top post about ‘Focus’, I had notifications working but when my DND would kick in at night I potentially might of missed someone breaking into my house…

Added the app to the non existent list.

The iOS 16 mess is not only about the notification service, things are even worse looking at the entities: anyone else experiencing this?