Set schlage user codes?

Tags: #<Tag:0x00007f77f4dd5ab8>

I’m having trouble setting user codes on my schlage z wave locks. Within the configuration > zwave > node user codes I see the code set for users 1 & 2, I cannot set or delete them, nor can I set any other user codes. After I “SET USERCODE” or “DELETE USERCODE” it just returns to the original code that came from the manufacturer. Any assistance you could provide on how to change them?

Which model…and did you add the lock securely? Do you have all other options/config menu choices etc that you should?

@Bartem I’m so sorry I didn’t respond sooner! I didn’t notice any responses. I have both a Schlage(Allegion) BE469 and BE469ZP and both are exhibiting the same symptoms.
As far as I know I do have them added securely. I have a network key set in my configuration file.
Lastly as for the options/config menu do you mean, do I have all expected panels in home assistant in general? If I get what your implying its whether I have an error in my config file, if I do it will screw up home asisstant and make things fail to load. Is that what you mean? If so yes I have everything I would expect, there are no issues with anything running and the UI looks correct.

Thanks for taking the time to respond!

Here is what happens, I set a new code by replacing the 0’s after each 3 with whatever I’m trying to set the code to. So what I see originally is \x30\x30\x30\x30\xa\xd and then I replace it with whatever the code should be in this example 5210 so I change it to \x35\x32\x31\x30\xa\xd. I hit submit and then moments later it blanks out the ascii field back to all zeros.

setusercode
setusercode1
setusercode2

Are you sure that code doesn’t exist in another slot already?

I meant all the “sensors” that are normally generated with the lock, thinking that would give us a clue if it wasn’t added properly somehow. Like alarm_type, alarm_level etc, there should be quite a few

couple of quick questions/statements.

Why are you adding the xa\xd to the end.

It should just be \x35\x32\x31\x30\

Also, zwave cannot read a code slot, so after you set a usercode, if you come back or refresh you will not see your code there. I suspect that you’ll find that just entering the 4 digits you want without the xa\xd will get you what you’re looking for. :slight_smile:

Even easier is

enter the node ID for your lock of course.

The clear usercode does not work though. But set usercode definitely does

Oh in that case, yes I am seeing all the expected properties associated with the locks.

As for the xa\xd at the end , it was already present when I go to that modification tab, I didn’t add it.

So I tried to set the lock the way you suggested, as I understand it. I erased everything and just stuck ascii characters in the slot. Unfortunately that resulted in the same thing as my last attempt. Also as you can see the “ascii” representation is wrong if you only put ascii characters into the user code slot. So I would assume it only accepts hex? usercode

This did work! Thank you so much!

Ok so I just set the code and then tried to clear the user code and it failed as you mentioned. I also tried deleting it from the same configuration menu where i had previously been trying to update them and that seems to fail as well. How are you deleting user codes via HA?

I was not saying enter the code in ascii, I was saying dont include the extra characters at the end

So…
\x35\x32\x31\x30\

Should also work.

You have two easy options to “clear a code”.

  1. Over write with another code. For me for example, I have only used the first few slots, so I just replace with another code if I want to change it
  2. Replace with an random code, that no one knows. The locks only let you enter a few wrong codes before they require a cool down period. The odds of someone trying 1111, 1112, 1113, etc and getting into your house is small.

The harder way is to update your open zwave manually and include the fix for the clear user code. I used to do that, but was a pain to maintain. There are many posts about it in the community.

I tried this and as soon as I click set usercode those trailing characters just append themselves again and the number changes back to whatever was previously there so it doesn’t seem like I am going to be able to change user codes via this method.

I’d like to limit the number of codes I have on my door and now that I successfully added one, bringing me up to three door codes I’d like to erase it completely if possible. I’m unsure of exactly what your describing in the last paragraph. Would this be a way to get rid of this third code completely? Are you just saying to physically open the lock and do some sort of hard reset on it?

Actually I was saying that Open Zwave is the code used to control zwave devices such as your lock. The code actually has a long standing bug that keeps codes from properrly being cleared. Open Zwave is not created by the Home Assistant Development community. Its a longer story than you probably care to know. Bottom line, is if you think you’re going to be clearing codes often, you can do my first two suggestions, or learn how to update the openzwave code to include the fix for that. That is what I was saying had several posts in this community on how to do so.

But, you gave me another idea. If you only have three codes, and want to clear one of them, and dont really plan on adding/removing codes often. Here is a trick that works

in the zwave settings for your lock there is an option for code lenght. 4 is the default
if you set it to 6, it will clear all codes
then wait for a min or two just to make sure the lock has cleared the codes
then try your lock to verify that none of your codes work
then go and set it back to 4
then set your codes back on the two slots you want…

Or to be honest if you only have a code or two, dont really need to change codes much, you might as well do it at the door. You can clear the code slot you want without HA at all. Clearing or entering codes at the door will not affect HA and the lock will still be fully controllable

Well your idea was correct! I set the user code length to 6 and after reloading the zwave page the codes were still in place; however they were rendered useless when I tested the codes from the door. It wasn’t until I clicked “Delete Usercode” that the codes disappeared. So in this instance the delete usercode function actually worked. I’ve now set the code length back to 4, set one of the slots and all is working as I had hoped! Thanks so much for sticking with me @ptdalen I wouldn’t have gotten this without you!

Happy to help. Just a quick bit of info. The “codes” you see when you open the zwave panel for the lock, are not the codes at all . The codes do not get sent to Home Assistant, only “from” Home assistant. I’ve just always. Basically HA does not know if you set a code on the door or clear a code on the door itself