Set the sensitivity for Xiaomi Vibration sensor through Rest API (Deconz)

Hi Forum.
I have a Xiaomi vibration sensor which I would like to use at the washing machine. But no matter how I position the sensor it won’t sense vibrations from the machine. I know that if you are using the Xiaomi hub you could set the sensitivity for the sensor but what if I’m using Deconz and a Conbee stick? I have found a thread at GitHub where they illuminate some Rest API codes which I was thinking whether or not were possible to convert into HA and or how to do so? :smirk:

Thank you! Rasmus

1 Like

You can use zigbee2mqtt:

In case someone is still having this issue, it is very easy:

Pull your bridgeid from core.config_entries under the .storage folder


Hi all
Sorry to resume an old topic. I was actually find a way to increase the sensitivity of my vibration sensor and came across this post. I tried to use the Deconz service as I’m using Deconz to present the entities to my HA server, but I’m not sure it changed something actually. Is there a way (other than trying manually) to see if the setting was at least applied somewhere?

I could not find a way to “display” the sensitivity setting, but upon changing it to 1, it was very obvious the sensitivity increased. I simply lightly knocked on the surface where I attached the sensor and noticed the vibrationstrength: attribute changing.
BTW, I gave up on my original use case for this sensor which was to determine my clothes dryer cycle ending. It triggers OK when starting, but stops sensing sometimes while dryer is still going.

Yeah I actually then gave it some more try and it seems it works not so bad, still maybe not perfect, but better than nothing in my mind. Thanks a lot for this hint and for replying to me !

1 Like

Hi Zoriontsu,
Your post regarding sensitivity was very useful.
Now, I would like to change the duration of the “ON” status.
So I am not forced to wait a minute before next event.
Du you know If there is a duration parameter for the vibration sensor?
On a motion sensor from xiaomi, I am able to adjust this by using the following data:

Service: deconz.configure

entity: binary_sensor.motion_bathroom
'duration': 10

That change would make my clothes dryer application work, but I could not find any way to modify how long the sensor reports ON. I created a binary_sensor template with a delay_off: to help compensate, but it still proved unreliable.

Is there any way to set the sensitivity through ZHA and a Conbee II zigbee coordinator?

Not that I know. I started moving my Zigbee devices to ZHA but had difficulty setting it up. DECONZ was very easy .

Hi there,
I just don’t understand where to get the “bridgeid”.
i have no .storage folder. i’m using unders a rasp pi 3b+

Thanks in advance,

Under the HASSIO config folder, there is a hidden folder named storage

Thank you so much for explaining this!
I can’t seem to find a value labeled bridgeid in core.config_entries
Is it entry_id, title, or api_key? Or is something else wrong?

Here is what mine looks like:

            "entry_id": "06cc0312296a418684ad1cbdc5206c31",
            "version": 1,
            "domain": "deconz",
            "title": "deCONZ-00212EEEFF05FB98",
            "data": {
                "api_key": "9FF80B8247",
                "bridgeid": "00212EFFFF04FB98",
                "host": "",
                "port": 40850,
                "uuid": "e09635b7-fdd7-41be-9ddf-e12024edbf1f"

Any reason why I don’t have those values in my file? Did I mess up the installation somehow?

I don’t have it either however I’m able to access it using URL as described on

Hello all,

I’m trying the same, detect the end of my washing machine job with deCONZ.
Currently, I detect vibrations every hour. Maybe the sensitivity is too high.
Have you observed same things?

I would like to send a notification 10 min after last vibration. What was your idea?

@tatouft I’m having the same issue. Mine sits on a door and keeps detecting motion every hour or so. Really frustrating.

@cayco Are you able to find the bridge_id using that link? It won’t show up for me there either.

The max sensitivity value is 21 not 1 ( 1 is actually the low sensitivty)

Hello i found the ID in “configuration” ->“integrations” page.
Look at the number under Deconz in Phoscon Deconz integration.