Setting a Tasmota RGBW bulb to white via Google Assistant

I have a RGBW bulb flashed with Tasmota. It’s working great in HA, I can set all the RGB and White values as I expect in the UI. However, when I ask Google to ‘‘Set the Light to White’’ only the RGB values are changed and a sickly pink/beige color is set. I’ve tried a number of different commands such as Pure White, Bright White etc and they all seem to set different values of the RGB but the white value is never set.

I’m able to set the white values correctly in HA using the white_value parameters in the light.turn_on service call. So if I create a script in HA to turn the light white and activate that script via voice command it works…but for non-technical household members it would be much better to be able to use the default voice commands.

The bulb is a Teckin SB50 and set with these options:

It’s running Tasmota 8.3.2 and is setup for auto-discovery in MQTT/HA.
I’m running HA 0.115 and have setup the Google Assistant integration directly.

Setting the light to different colors, such as red/blue/green all work fine via Google Home/Assistant…it’s just the white value that doesn’t seem to get passed correctly.

Thanks for any suggestions,

I have the exact same problem with an RGBW led strip. Did you find a way to make this work?

I haven’t tested it yet, but came across the rgbwwtable setting in the tasmota lights page:

Let me know if you get a chance to try it.