Setting Up Bluetooth In Linux Deploy

I’m trying to setup the Bluetooth integration for Home Assistant which installed through Linux Deploy. The setup wizard doesn’t work because it doesn’t detect any Bluetooth adapters. I’m running this through an S7 edge which has a bcm4359 WIFI/Bluetooth combo chip. I’ve ran hciconfig, bluetoothctl, dmesg grep -i blue, and rfkill with Bluetooth tethering on and off which all return nothing except for rfkill, which does show a Bluetooth device. I’ve also tried connecting a Bluetooth adapter via an 0TG cable with no output as well, but it does show up in lsusb. I’m also using debain if that helps (tried 10 and 12 which also doesn’t Work).

Hey Jakethe1stdog,

It would appear that you are having trouble setting up Bluetooth on Debian using Linux Deploy. Since you have already tried a number of options and approaches without success, the following steps can be taken to fix the problem:

Bluetooth Service: The command “sudo systemctl status bluetooth” can be used to verify that the Bluetooth service is running. Start it with “sudo systemctl start bluetooth” if it is not already running.

Updating Firmware: Update the firmware for your bcm4359 chip. You can install firmware updates that are specific to the model of your device by searching for them.

Kernel Modules: Using “lsmod | grep bluetooth,” determine whether the Bluetooth-specific kernel modules have been loaded. Please manually load them with sudo modprobe module_name> if they are missing.

Device Detection: Use ‘sudo hciconfig - a’ to check in the event that your Bluetooth connector is recognized and its status. Check for any warnings or errors that might point to problems.

Permissions: Make sure that your user has sufficiant permissions to get to Bluetooth devices. Using “sudo usermod -aG bluetooth username>,” you can add your user to the Bluetooth group.

Restart Services: Use “sudo systemctl restart bluetooth” and “sudo systemctl restart dbus” to restart the Bluetooth service and any related services after making any changes.

Testing: Check to see if your Bluetooth devices have been detected by running “bluetoothctl scan on” once more.

You can try all these possible ways to get out of this issue.