Setting up emulate_hue

So I’ve been searching these message boards to find out how you set up the Alexa side of this control system? Does anyone know how to do this? I’ve set up my configuration side, but I haven’t been able to get the Alexa side working. Discovering devices does nothing and I’m not convinced that it is even talking with home assistant. I assumed that you selected ‘search for hue bridge’ when setting put he alexa side but it found nothing. Does anyone have a step by step set up of the Alexa side? Or can someone explain what alexa skill to get?

Have you asked Alexa to discover devices?

Re Dave

Yes, im switching from the haaska method to the emulated hue method because haaska takes ~3 seconds to turn on lights. Someone said emulated_hue was faster.

So when I tried to enable the philips hue “smart home” skill it tried and failed to find a bridge. This was after I was forced to sign up for a Phillips hue account. I want to know if this is the correct process to get it working? Does anyone have a step by step process for the Alexa app side of this setup?

I know for a fact that the HA side is set up properly because when I go to the following addresses, I receive the expected information:

http://< HA IP Address >:8300/description.xml 
http://< HA IP Address >:8300/api/pi/lights

So when I set up the alexa app, this is what i’m doing. Please someone correct me if I’m wrong:

  1. Open app, go to Smart Home tab.
  2. Click “Get More Smart Home Skills”
  3. Find Phillips Hue Bridge skill.
  4. Log in to hue and attempt to connect a bridge.

This fails because I don’t have a bridge. My assumption is that HA is attempting to be the bridge. Is this the wrong assumption?

If you are using Emulate Hue you dont use skills, you set up emulated hue in your config, indicate what devices you want Alexa to see, and then ask Alexa to discover them.

See, this is how I got mine working with help form other members

Re Dave

Yes, I was over complicating the ‘discovery’ process. I was treating like the SmartThings integration I moved away from. Either way, it still wasn’t working for me for about 2 hours. About 2 minutes ago it just started working. I’ve been diving into my network configuration… not sure what I did. Thanks for the clarification.