Setting up HTTPS access, but need some assistance

Hi Everyone,

I’ve been running HA for a while now and loving it.
I have forwarded port 8123 and just been using the non secure port externally, yes, not the best idea at all.
I run an nginx server and also have my own domain name.
I also utilise CloudFlare to provide some IP protection.

Currently, I have…
This is how I access it externally.
I would love to have
With nginx, i’ve made several applications available externally with the above scenario working perfectly.
I do also have static external IP’s which helps as well.
With HA though, I just can’t seem to be able to get the result.
I would’ve through that i’d be able to access the https site internally, but it says it doesn’t exist.

Any and all help would be very much appreciated.

Does anyone have any ideas on how to fix this?

The best and simple way is to used Nginx Proxy Manager Which not only forward your domain to the right IP also help you create LetsEncrypt SSL automatically.

In my case I run my NPM on different server. Then NPM will redirect my connection to my local http://ip:8123 This way I’m exposing single machine which only job is redirecting traffic internally

Thanks for the reply.
I’m very familiar with nginx, I run 6 hosts off it already.
My concern is, how can I expect nginx to push traffic to an IP and port internally that I can’t access locally?
Shouldn’t I be able to got to https://HA_IP and be able to access the secure page?

The way you do it (if you have static IP) you redirect your cloudflare domain to you static IP. Then make sure your router allow to forward port 80/443 to the NGINX server. Once NGINX get the information it will forward that domain to the right/correct server:port.

Again with NGINX Proxy Manager you will done it easily without having to touch the conf. But up to you. Make sure foward_pass is correct and all the proxy setting on NGINX

My current nginx host for HA

Does this need to be done?

Yes, or it will not work.

Most 100% sure you will required this if you are running 2021.7

Running 2021.7.4

I added the lines to the config, now I’m getting image

What shoud the port config not be in nginx?

think i’ve got it all sorted now…

points to

This look right?
Seems to my end.

http uses port 80 and https uses port 443… so…no…it doesn’t look right :nerd_face:

http://hosts(:80) refers to http://x.y.z(:80)
https://hosts(:443) refers to https://x.y.z:8123
I’ve added the ‘native’ port numbers in brackets to clarify, they can be used but are optional …

Like I said above, how can I point nginx to a port/page that I can’t access internally?