Setting up Mosquitto broker add-on in Hassio

I have problem setting up the Mosquitto broker add-on in Hassio.
I receive following error in the logger:

[20:32:54] INFO: Setup mosquitto configuration
[20:32:55] INFO: No local user available
[20:32:55] INFO: Initialize Hass.io Add-on services
[20:32:55] INFO: Initialize Home Assistant discovery
[20:32:55] INFO: Start Mosquitto daemon
1578598375: Loading config file /share/mosquitto/acesscontrollist.conf
1578598375: Error: Duplicate user value in configuration.
1578598375: Error found at /share/mosquitto/acesscontrollist.conf:1.
1578598375: Error found at /etc/mosquitto.conf:29.

I have following file structure
image

And the Mosquitto broker add-on has the config:

{
  "logins": [],
  "anonymous": false,
  "customize": {
    "active": true,
    "folder": "mosquitto"
  },
  "certfile": "fullchain.pem",
  "keyfile": "privkey.pem",
  "require_certificate": false
}

I don’t understand the error.
Somebody that can give me a hand?

You showed us the file structure, but not the contents of the files.

1 Like

flamingm0e what do you mean?
The content in the file is
acl.conf:

acl_file /share/mosquitto/accesscontrollist

acesscontrollist.conf:

user mqtt_fredda
topic readwrite #
#user homeassistant
#topic readwrite #

I comment out the homeassistant user in acesscontrollist but it didn’t make any different.
What should the content be?

If you are using the ACL, remember to enter the newly created user and homeassistant in /share/mosquitto/accesscontrollist as follows:

So does the user exist in your home assistant?

Create a new user for MQTT via the Configuration > Users (manage users) . (Note: This name cannot be “homeassistant” or “addon”)

Yes, I have created a new user in Hassio, Configuration > Users (manage users).
User “mqtt_fredda”.
Now I even tried to delete and creat the user again.
But it still gives me the same error.

I’m also having an issue getting Mosquitto going. I have a raspberry pi3 and I’m trying to run it on my GoControl zigbee dongle. This is the error I’m getting (please help):

code ELIFECYCLE
npm
ERR! errno 1
npm
ERR! [email protected] start: node index.js
npm ERR! Exit status 1
npm
ERR!
npm ERR! Failed at the [email protected] start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
npm ERR! A complete log of this run can be found in:
npm
ERR! /root/.npm/_logs/2020-03-11T06_23_43_346Z-debug.log
2020-03-11T01:23:44: PM2 log: App [npm:0] exited with code [1] via signal [SIGINT]
2020-03-11T01:23:44: PM2 log: App [npm:0] starting in -fork mode-
2020-03-11T01:23:44: PM2 log: App [npm:0] online

[email protected] start /zigbee2mqtt-1.11.0
node index.js

My configuration looks like this:

1 data_path: /share/zigbee2mqtt
2 devices: devices.yaml
3 groups: groups.yaml
4 homeassistant: true
5 permit_join: true
6 mqtt:
7 base_topic: zigbee2mqtt
8 server: ‘mqtt://core-mosquitto:8883’
9 user: my_user
10 password: my_password
11 serial:
12 port: /dev/ttyUSB1
13 advanced:
14 pan_id: 6754
15 channel: 11
16 network_key:

Etc.

There is an error here:

“Loading config file /share/mosquitto/acesscontrollist.conf

cannot have the .conf in accesscontrollist, only the acl.conf has to be loaded and only then call the accesscontrollist