Setting up z-wave from scratch on Synology via docker

Guys, I am terribly lost. I have HA running just fine on my DS1019+ still happily running DSM 6.2. I bought a zooz S2 stick and would like to set up my z-wave network. I’ve found and read 100 threads about how to accomplish this and the more I read the worse it gets. Is there anywhere a concise guide for how to make it work (assuming nothing goes wrong)?

So far, the synology doesn’t see the stick and the site hosting the drivers ( ) is gone. Also I set up the docker container for zwavejs2mqtt via Docker UI on the synology but can’t access it at I am very confused.

Could someone please point me in the right direction? I’m trying to learn but I’m struggling. Thank you so much!

I have a similar setup on Synology using dsm 6.2 and an Aeotec Gen 5 stick,

For me it shows up as /dev/ttyACM0

ssh into the NAS and see if this device exists.


For the zwavejs-ui container, run it in privileged mode, provide a location for it to store its data and then select use host network. Then add 8091 to your firewall.

Post your config.

I’ve tried both the back and front USB ports and I’m not seing ttyACM0 or ttyACM1 or ttyUSB*. And from the Synology UI, under Control Panel > External Devices, I don’t see anything. Are there any drivers that I need to install?

If Z-Wave is the only thing holding you away from DSM 7, it should be safe to upgrade according to this thread:

I don’t see anything in external devices except the USB drive that is used for the encryption keys.

Do an ls of dev with the stick unplugged and with it plugged in, any changes?

Are there any other usb sticks attached to the machine? This poster had a really hard time getting their zstick to work but they also had a zigbee stick. Ultimately they needed to a UDEV rule and move the zstick up to a higher ttyacm#

See this thread as well

Synology has a locked down OS you can’t make many changes to and are trying to workaround a lot. As you can see by the headaches in those attached posts, along with many other people having problems with synology and zwave and zigbee sticks, I personally would avoid running Home Assistant on synology if you want to also use zwave and/or zigbee sticks.

If you want to keep trying though, per this post, try and install the container through the command line instead of the synology UI:

Guys, thank you so much for all the advice. After banging my head against the wall for nearly a day where the stick would not be picked up (no changed in /dev after insertion and also no zigbee stick), I decided to say the hell with docker and I set up HA in a VM. HA let me set it up as soon as I installed the z-wave JS integration and everything has been working fine. I tried everything recommended here and also everything recommended in the 20 posts I read on similar topics in this community or on reddit. It’s frustrating. But I’m now set up. Thank you and happy holidays!