Setting up Zigbee motion detector


I did some first steps with Zigbee. For this, I bought a “SilverCrest” ethernet/zigbee gateway and modified it according to Cloud-free integration with Home Assistant - PaulBanks.Org. Then I added a motion detector, also SilverCrest (sold by Lidl).

Up to here, all worked pretty well. Modifying and adding the Gateway worked great. Adding the device also worked as expected.

My problem is that the motion detector entity of the device is almost always unavailable. The device entity itself goes offline after a while if there is no motion but reconnects when motion is detected. Did I miss something in the configuration?

Status of device entity:

Status of Motion detector entity:

I cannot speak for the device itself, I am using (also cheap) SonOf detector but this is always connected. Posisbly the silvercrest is trying to save further battery by disconnecting? This should not be a real issue as long as it does come online quickly and updates the status when motion is detected, or?

It reconnects properly on motion detection. Nevertheless, the “motion detection” entity remains “unavailable”.

I just browsed the net as I was also thinking of trying these out myself, and found quite a few odd issues with Lidl related to power saving but also other odd behavior. For now I will stick with Sonoff…

SilverCrest (Lidl) motion sensor - usage and control logic problems - Advice - deCONZ Community (

I deleted the device and re-added it. Now the “Motion detector” entity does not appear anymore :-/

I have the same problem with this. Likewise with the smart button from Lidl. That button turns itself off. I got around that by adding it to the automation so that it would be activated again. I don’t like that, because then double click or longpress doesn’t work. But at least something. It is different with the PIR sensor, it cannot be done the same way. I read in another thread that it works over ZigBee2MQTT. But I don’t want to install another server/gateway into the system because of that one device. This requires either docker or another RPi.