Setting up Zwave2MQTT

Tags: #<Tag:0x00007f3263605a80>

I originally installed through configuration/integration the ZWAVE integration which I understand is 1.4. Install a Aeon Labs Z-stick Gen 5 which went fine. Then wanted to setup a ZW112 Door Window Sensor 6 (AEON Labs) which paired fine except it did not report when the door was closed. Read lots of posts this was a problem under Openwave 1.4 and was fixed in 1.6, so to decided to install Zwave2MQTT as I understand this is on 1.6.974.

Got that installed okay but I still get the same results where it will not report a closed state. Now I did notice something odd. In the control panel the Last Active beside the nodes appears to only be updated the first time a device is added or when a reboot occurs. I also noticed that the battery value of the door/window sensor didn’t update after it was charged. It also shows the device having a status of Sleep.

I am trying to get this all moved over from Smartthings and am trying to get some clarity on how this all works and if I am going down the right path. Hoping someone can help put me in the right direction.

Thanks

I too moved from SmartThings to ZWave2MQTT. However I don’t have a ZW112, but will suggest a couple of things.

  • On the CONTROL PANEL webpage, goto the bottom right and click on DEBUG. Then open/close your door/window. Check the DEBUG output. If there is something there that makes sense and you think it is detecting open/close properly, then it likely means there is something in the MQTT messaging or MQTT setup that is not working. If you are using MQTT auto discovery, its possible that HA is receiving the MQTT messages but not understanding something correctly.
  • If the DEBUG output looks like it is not detecting open/close properly, then goto Settings->ZWave and turn on Logging. This will cause OpenZWave logging output to showup in the DEBUG webpage. It is rather detailed output, but will provide more insight as to what may be wrong. Note: this will cause zwave2mqtt to restart.
  • Battery operated devices are sometimes tricky to get fully operational. There is a lot of interrogation that openzwave does to learn all the class commands that a device can report out. It could be that openzwave did not learn about the particular class command that gets reported on an open/close. If the OpenZWave logging reveals that openzwave got a message when the device was open/closed but didn’t understand it, then you probably want to wake up the device a few times so that openzwave can attempt to reinterrogate the device fully. Wake up the device the same way you would do to get the device to join (like hold a button in for 3 secs).

The zwave2mqtt addon works with the zw112 door/window sensor of aeotec.
After litterally hours of troubleshooting, looking through code of the openzwave, zigbee2mqtt and the hassio zigbee2mqtt-addon (and resetting my network multiple times) I found out that in order for the zw112 to report it’s contact state you need to:

  1. Pair your zw112 device by starting the (non-secure) inclusion in zwave2mqtt and pressing the pair button once.(Note these steps might also work in secure mode. however I did not verify this)
  2. Select the zw112 device and expand the node configuration bar
  3. go-to “Report type to send” and select “Basic Set and Sensor Binary Report” and submit it.

    3a.(Optionally: press the pair button of the zw112 to force it to come online to get it’s latest config parameters)

After following these steps the zw112 device reports the contact value correctly to home assistant.

Thank you so much for coming back to this thread and reporting you solution. I had put moving to Smartthings on hold.

One of the things I want to overcome is the placement of the Aeotec stick. Right now it is in the basement on the server rack which is not ideal. It’s on a Raspberry Pi which also has a serial connection to my Monoprice Amp so can’t move it. My plan is to get another Pi and run my ZWAVE and Zigbee devices remotely in a central location (where my Smarthings Hub is currently located). After I get that setup will try again.

An update. I finally got my remote PI up and running with ZWAVE2MQTT and Zigbee2MQTT. I was still have a heck of a time getting these Zwave sensors to work. These were the first I tried with this setup. After much trial an error I got one of them working fine but struggled with the second one. I had read that Zigbee was sensitive to being plugged into a USB port directly and it could impact reception and they recommend an extension cable. So I tried an extension cable on the Zwave adapter and now it works perfectly.