Setup Ecowitt weather station (WS 5500, aka WS 2900)

My favorite weather integration Buienradar started not updating some days ago, and because it has been the most reliable and correct service I had been using for years in my area, I was ‘forced’ to find another reliable source of weather data.

Why not try local, and use your own station? Sure, why not. Seems kind of cool to be self sufficient in that regard too :wink:

As it happened, there was a discount(…?) on an Ecowitt WS 5500, so I ordered it. And then the trouble started. No matter what I read in the manual, and followed all steps successfully, the display (which connects to your wifi router And to the weather device outside) would not shake hands correctly.

First try the Shortcut/Preferred method, no app required

After I wrote the Guide below, I found what I had been looking for at first… scroll down to the indicated section and find the 2-step way to login to the Weather station.

Display panel needs mains

Just so you are aware upfront: as Ive just experienced, the Display panel needs the adapter power to connect to the router.
As you will walk through the below steps and hopefully connect your device to the router, you might think you can do so with 3 AAA batteries only. Dont. I had, and, because of obvious mobility advantages, I decided to use batteries in stead of the mains power adapter. Only to find it loses connection to the HA integration (and app). Or, should I say, to the router. Connection to the Weather station itself was preserved.
So, until I read elsewhere we should be able to do so with some setting, I keep the mains power adapter in place.

The Home Assistant documentation on Ecowitt was followed to the letter, and yet, nothing happening… arghh now what.

The Ecowitt manual mentions using the Ws View app, so I did, and ran the procedure endlessly, making sure all wifi considerations (WSAPK, only 2.5ghz channel) were met.

I think Ive held those 2 buttons Wind/Pressure for 5 secs to set it in setup mode about 50 times.

What bothered me was the fact the WS View app didnt ‘scan’ the wifi channels (you do have to allow it to do so when installing the app, and give it some other authorizations along with it). It picked the wifi my Phone was on, and I had to manually enter/paste the password. All a bit clunky interface.

Each and every time the app reports:

Gateway connected, return to your Wifi on your manual device.

Seemingly indicating succes.
No such luck though. Running the config flow in the Integration (no discovery here, just install it manually and add an Item) returns a web hook string, a port and the ip address of the HA instance.

Simply following the instruction and entering those didnt help either. Guess I silently hoped the device would connect, even if not showing up in the apps devices list.

Well, it didnt connect. Nothing listed.

And that’s when I decided to stop following documentation/manuals and experiment a bit…

The HA docs mentions the Ecowitt app, but that requires an account, and I want things local only. There are several other apps, but none seem trustworthy. The best contender seemed WS View Plus. Same brand/maker, (is it Chinese? it is Chinese) and rather disappointing reviews.

And yet, I had to try something.

  • Install WS View Plus

Firing up that app did offer a much better user experience. Most importantly, it has a Scan network functionality that actually works.

So (and this is the main part of this post)

  • Hit that scan button, and find your preferred Wifi Sid. Select, enter PW, and: bingo.

The Display immediately got the correct time/date settings, and the other options were kicked to life, showing real time local (!) data!

Also, you now have a Device in your device list in the app, which you are supposed to connect to any service you should desire. I only wanted Home Assistant as all others are cloud based.

I then ran the HA integration setup again, and that produces an info screen with all data you need to enter in the App settings after this.
However, contrary to what it states in bullet 5 of the HA documentation:

  1. Path has to match! If using the Ecowitt App, remove the first forward slash from the API token, as the app will prepend one.

one has to truly C&P the complete web hook string, and do so INCLUDING the leading / in the app settings.

Because of this string I can’t recommend strongly enough to run the config flow on your mobile device from HA. Otherwise you have to manually type it, and its a bit prone to errors

Where to enter the HA web hook
Finding the correct place in the app is also a bit getting used to. Easy to miss because of the non default elements in the screen.

  • open the WS View Plus app, and select the now listed device,
    you see an element resembling a menubar with left and right arrows.

  • Click right, until you see Customized

  • on that tab, first enable Customized, and select Ecowitt

  • then enter you HA instance Ip (only numbers, no protocol)
    paste the web hook string from the HA config flow
    paste the port from the HA config flow

Lo and behold.
Once I had done that, the Ecowitt integration populated 26 sensor entities,

a notification popped up about a newly discovered device_tracker, and the integration panel showed:

Notice how the Integration recognizes the device as WS2900_V2.01.18 and not WS 5500. Might be useful to be aware of that, as the numbers float around the internet wildly

Next, I shoved the station on a broomstick for testing purposes and moved it outside :wink:

Rain started, so I hope to see some of that in the data it should be collecting

might be a bit lengthy, but I tried to be as complete as possible, and prevent some future frustration for fellow community members.

Btw, now the device is setup correctly, you can also open a webbrowser and login to its ip address. NO PW is required for the first login as admin…

all can be configured at http://<local ip of your device>/weatherServices.html

Shortcut/preferred method without app?

I now (after writing the above… sorry) find:快速操作流程图%20PA0902360H10%20展开尺寸为297x370mm%20折叠后尺寸为74x123mm%20(80g书纸%20黑白单面印刷%20风琴折).pdf (I didnt put this under a link, so you are aware of its origin)

I can not read the url, but is suggests we dont even require an app to install the device.

  • log in to it directly after connecting the Phone to the wifi of the device when in ‘pairing’ mode, much like we do with eg Shelly devices.

It was what I was looking for, and couldnt find, simply because I wasn aware of the default embedded webserver at

  • which you open in a browser on your mobile device

O, and do

  • block internet from/to the station in your router after checking its firmware version. One never knows…

If you didnt use the Shortcut method, and used the WsView Plus,

  • you can delete it once everything is working. No need for that anymore, and you dont want the app to do anything suspicious…

You could try this for further information:

start [Wiki - Fine Offset Ecowitt Ambient Weather Stations (and clones)] (

and - Index