Setup edl21 does not work?

I tried to simple setup my IR sensor with edl21 with USB.

I added this to my configuration.yaml

      - platform: edl21
        name: Stromzaehler
        serial_port: /dev/ttyUSB0

But it doesnt work?
I dont see anything in my developertools or something? Also i dont have something in “Logs”…

How can i know, if it work or something? I think i am to bad for it :frowning:

Can someone help me or is there an tutorial somewhere for the german IR Lesekopf setup?

Hope someone can help :slight_smile: Doesnt find any tutorial or something

1 Like

I also tried this:

  - platform: edl21
    name: Stromzaehler
    serial_port: /dev/serial/by-id/usb-Silicon_Labs_CP2102_USB_to_UART_Bridge_Controller_0065-if00-port0

That path of serial_port is directily to my usb… i checked the path and its the IR Reader but i dont get any informations in developertools or something?

1 Like

Same here. I think the platfrom does not work. I also saw, that the IR sensor does not bilink or do something…

has anyone help?

It is working now. after reading the logs. I found out.

Hello, I have the same problem. I do not see any EDL21 entities in my list and even the logs say nothing. I guess the problem will be solved if this open issue is closed …

Same problem here. What can I do after I’ve added the sensor to the configuration.yaml?

Any solutions yet? I have the same problem

Reboot :wink:

But you can try dsmr which at least produce log entries.

Having the same issue. Manual read works fine, edl21 nothing happens, dsmr reacting strange… it getting the entities, but not showing the values

What was the issue and how did you solve it? Mine is blinking fine, but no logs at all … even with debug.

By the way: I really like vzlogger2mqtt (ha-addons/vzlogger2mqtt at master · m-reuter/ha-addons · GitHub).

I have unfortunately learned that edl21 cannot read many readers (some D0 and some SML meters) or cannot read them completely (not all OBIS-codes).

So I switched to the addon. And it wasn’t really difficult either. You only have to deal with the technology (protocol, baud rate, etc.).
I was lucky that I could draw on my experience with the FHEM-module (other home automation). I do not regret it.

I had a similar problem, too. My solution was to configure the USB serial port correctly, according to the instructions in the manual of my Weidmann sensor:

stty -F /dev/ttyUSB0 9600 -parenb cs8 -cstopb -ixoff -crtscts -hupcl -ixon -opost -onlcr -isig -icanon -iexten -echo -echoe -echoctl -echoke


1 Like

Didn’t changed anything in my case… Neither for EDL21 nor for DSMR.

I thought I have the same problem, but the entities are there. Go to the menu “Devices & Services” (Geräte und Dienste). On the top menu you can select entities and search for the string edl21.
If your sensor reads data (e.g. from /dev/ttyUSB0) then you will find some entities. Now you can modify the region (Bereich) where the entities belongs to. I hope this helps for you.


what “device” has be entered when sensor is remote (via socat or ser2net). I tried : and socket://: - both did not work.