Setup failed for fullykiosk: Integration not found

Hi all

after the message that fullykios is now a Home Assistant core integration, I’ve removed from HACS and now I get this error in log

Logger: homeassistant.setup
First occurred: 11:30:13 (1 occurrences)
Last logged: 11:30:13

Setup failed for fullykiosk: Integration not found.

I’ve checked with Visual studio for an occurence in yaml code, but I haven’t found any

What else can I check?


Does your system have the “core” integration installed?

1 Like

No, but, as far as I know, I don’t have anything using it.
I had the HACS integration installed probably because I tried it, but then I forgot to uninstall.
The only thing I can imagine using it is Browser Mod.

What should I check to see if something is using it except yaml files?


Have you set up the integration?

1 Like

The official integration is named fully_kiosk, with an underscore.
Maybe look in .storage for reference to the old one.

1 Like


the only files where I see fullykiosk are here

What should I look into .storage folder and, if needed, how should I delete the fullykiosk references?

I also have received the same error (ERROR (MainThread) [homeassistant.setup] Setup failed for fullykiosk: Integration not found.) since updating today.

I saw no reference to a breaking change, after re-reading the release notes for the last 4 versions.

Oh, I do love that the integration page now shows the warning that it didn’t load! I would not have known there was an issue until an automation failed tomorrow. So kudos for that improvement! Integrations page looks great now!

Have you find any solution?


Nope, I did not. I hope to find a little time to look more tonight after work. I tried deleting my Fully integration completely and setting up from scratch. That did not work and I ended up going back to a backup.

1 Like

You could try to replace the integration name in your .storage/ files:

sed -i 's/fullykiosk/fully_kiosk/g' core.device_registry
sed -i 's/fullykiosk/fully_kiosk/g' core.config_entries
sed -i 's/fullykiosk/fully_kiosk/g' core.entity_registry

and restart HA. But be sure to have a BACKUP if something goes wrong!

1 Like


It seems that the error does not appear anymore

Even if I haven’t installed the new fully_kiosk integration and I have removed the old fullykiosk

Glad you found a better solution. This afternoon, I manually edited the three core files and deleted all of the fullykiosk entries, then just added all my my kiosks back via UI. Working great now. I will absolutely note the solution above for next time I have a similar issue!

Hi, where do i put the in the sed commands referenced above, i manually edited device_registry and config_entries but entity_registry has a lot more entries and was hoping to not have to edit each one. Thank you