Setup failed for meross_cloud: Integration not found

Hi everyone ! Any advice ? I can’t delete my meross app and have this error on it : Translation Error: The intl string context variable “logs_link” was not provided to the string “Non chargé, check {logs_link}”

[4:57 PM]

and then in the error log i have this 2021-05-14 14:38:12 ERROR (MainThread) [homeassistant.loader] Error loading custom_components.websocket_api. Make sure all dependencies are installed 2021-05-14 14:38:12 ERROR (MainThread) [homeassistant.loader] Error loading custom_components.meross_cloud. Make sure all dependencies are installed

[4:59 PM]

Invalid config The following integrations and platforms could not be set up: hacs meross_cloud

Bottom line, I am unable to use any meross device.

Hi I have the same problem here, and I would like some help too, but I think the dev of meross integration stopped supporting it

Try to reinstall it.
Meross Cloud IoT installed via HACS works fine here.
Also check out this thread:

Yes, I have done all the suggestions of my previous thread, I did reinstall it I even made a new account for Meross app and tried to install the integration to HA but the problem remains.

Pruhst - sorry Makis, I totally missed it somehow, that this older thread was started by you.

But does this mean, that you’re having this problem since May last year?
And if so, in the older thread you show that you run Python 3.7 which is depreciated since HA 0.116 and support removed in 0.118.
Nevertheless, in the old thread I also can see that you run HA on a nuc, but can’t find any other information, for example about the version.
It would be best for both of you, when you provide informations about the HA version you’re running and log entries regarding the merros problem.

1 Like

Thanks for your suggestion Joerg. I have already report it in the github repository, and in general is a knowe issues with this meross devices. Eventually I will remove them from my home and buy something more HA user friendly like tuya etc. :slight_smile:

The problem of last last year it was resolved with an update after a few days, so after almost a year a new one appears.

The good news is that the developer (which is trying hard) have announced the following, but I don’t know when the update will be released. I guess after a month at best.

` ❗ Heads up: Update ❗

I had promised to the community that I would have focused my development efforts in the local-addon, and... so I am doing :) As already mentioned many times, the reason why it takes so much time is because everything done here is the result of hours and hours of procotol inspection sessions, reverse engineering and [hacking](

Just to rise the hype, here there are some screens of the on-going development addon, which is 75% completed:`

albertogeniola/meross-homeassistant: Custom component that leverages the Meross IoT library to integrate with Homeassistant (

Okay and you’re welcome.
Today I noticed there seems to be a new Meross integration which claims to work with MQTT:

This homeassistant integration allows you to control your Meross plugs all over your LAN without any need for cloud connectivity. It works through your own MQTT broker (or any other configured through the homeassistant mqtt integration).

Maybe this is something for you?

maybe not all devices are supported yet :frowning:

You are correct. This what I need, however although I tried to install it last week it is difficult to implement for my skills. knowledge and available time I have at least for now.

1 Like