Setup hassio on raspberry pi3 with raspbian jessie with pixel

How did you access it?
[email protected]:~ $ sudo ./hassio_install -m raspberrypi3
[INFO] Install supervisor docker
[INFO] Install generic HostControl
[INFO] Install startup scripts
[INFO] Init systemd
[INFO] Start services

When I try to load home-assistant in my browser (ip_of_pi:8123) it will not load

I have the same problem… I installed it with command “sudo ./hassio_install -m raspberrypi2” and everything was successfully finised. On MY_PI_IP:8123 don’t run hass.
I checked docker images after installation: there are 2 images … hassio-supervisor and raspberrypi2-homeassistant. But actually, there is running only one container (supervisor). It is OK?

try this:

sudo su -

then run the script. after run the script type exit command to stop being root.

If your using this method with stretch you need to do the following

add
cgroup_enable=memory cgroup_memory=1 in /boot/cmdline.txt at the end of the line and reboot.

So I am in exactly the same situation. Using a Raspberry Pi 3 with raspbian stretch and pixel. I’m using the HDMI output from the pi and also need to install other applications but I want to use hass.io so I can make use of the add-ons, things like updating hass at the click of a button is a huge benefit. I’ve currently followed all the steps that people have talked about above. I’m currently looking at the house logo and it’s been sitting here for about half an hour in the web browser.

Approximately how long does it take for it to initially start up for other people?

2 Likes

@Andy_Nunes

Here’s my guide based on my tests and info above.

NOTE: It is not possible to install packages on Hass.io7. You’ll need to create an add-on to run an application besides Home Assistant: https://home-assistant.io/developers/hassio/addon_development/120

It is not possible to have applications interact directly with Home Assistant. You can have add-ons communicate via MQTT https://home-assistant.io/hassio/run_local/43
How to add VLC into my Hassio?

Ref: How to add VLC into my Hassio?

Installing HASS.IO on top of Raspbian Stretch on a Raspberry Pi 3

Note, I found a 8GB SD card insufficient as it ran out of space during the setup meaning HASS hung during the preparing Hass.io stage. Changing to a 16GB card fixed this issue.

Requirements
As per home-assistant/hassio-build prepare the system.

Update the apt package index.
#sudo apt-get update

docker
Install docker-ce for the Raspberry Pi. Info source: Get Docker CE for Debian
Install the latest version of Docker CE

#sudo apt-get install docker-ce -y

bash

#sudo apt-get install bash -y

socat

#sudo apt-get install socat -y

jq

#sudo apt-get install jq -y

curl

#sudo apt-get install curl -y

avahi-daemon

#sudo apt-get install avahi-daemon -y

dbus-daemon

#sudo apt-get install dbus -y

Alternatively combine all into one command:

#sudo apt-get install docker-ce socat jq curl avahi-daemon dbus

Add @Philippe_Audet’s edit to the cmdline:

#sudo nano /boot/cmdline.txt

append cgroup_enable=memory cgroup_memory=1 to the end of the text file, then reboot:

#sudo reboot

Installing HASS.IO
Download the installer:

#sudo wget https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install

Add the execute permissions to the file:

#sudo chmod +x ./hassio_install

Then run it with:

#sudo ./hassio_install -m raspberrypi3

4 Likes

does the above still work with the latest version of hassio?
any can confirm this or anyone has this setup working still?

my current is debian stretch (dietpi)

And do you know how to do it in Ubuntu? I don’t have the cmdline.txt file.

Thanks fir your help

FWIW, I started an with a fresh stretch lite on a pi3, and used this
hassio install on stretch lite

Seems to work fine, but I am a newbie lol

1 Like

But I’m not using a pi. So the instructions are not valid for me.

I am stuck here, docker is already installed

image

follow this:

is it possible to have the Hassio add on menu on the docker ??

I don’t have experience but what i did i tried it twice and work fine , and my to use the screen of the raspberry without need another raspberry or tablet or second screen
1- I installed raspbian ( i use pc to install screen driver)
2- i installed hassio + docker following the steps above
Now i can run hassio in raspberry and also in pc or mobile connected to the same wifi network with radpberry.
Hassio start automatically when restart raspberry but it take few minutes

  • The next step i will flash sonoff and try control it from the raspberry screen , i hope that success and work.
    I hope that help or someone will help you

do you have the addon store when installed on raspberry ?

yes of course

1 Like

Thanks a lot :slight_smile:

i am done with the docker installation, what is the command to install the latest version of hassio ?

follow the steps above guide of Richard.Huish
if you already installed hassio so use this command:

**$ pip3 install --upgrade homeassistant**

if the update unsuccessful use this command (it work for me):

**$ sudo docker pull homeassistant/home-assistant:latest**
1 Like

@seghier Tried with the above, still the same

cant find the add on tab