Setup MotionEye core integration with Ingress/addon host

As many of you know, Home Assistant Core got updated today. One of the new integrations that was added is MotionEye. This allows you to integrate motioneye cameras without manually configuring them. I saw some people mentioning issues to connect to their instances, including myself. Should be noted that these are instances that are running by home assistant supervisor or OS. I.E: Ingress.

In order to make it connect, you must enable the web interface port in the addon configuration. I havent tried this, but I also disabled ssl as well.
For the integration, leaving a password space empty with throw an error in the integration setup process. You have two options, (that I tried at least). If you dont have a password in MotionEye set, you can enter the user in the user field, and simply hit the spacebar in the password field. It connected fine for me, BUT I DO NOT RECOMMEND THIS. This kind of setup is likely to cause errors in the future, as updates are pushed through.
Instead, just create a placeholder password(s) in MotionEye and use those.

For the URL, format it as a regular url, in my case, “
That should be it! Connect and view away! Hopefully this helps!

thanks - would be nice to have a user-friendlier connection to the add-on…

Im sure in time a more friendly config will be deployed. Because the integration is brand new, I’d give it some time to mature and change. Glad this could help!

1 Like

Do you have an idea if it’s possible to use it with duckdns and how?

I access my instance so I’m guessing the port :80 for the addon won’t be accessible from the outer world. Right?

Of course the integration doesn’t find the server :frowning:

I just found this reply which helped me:
Home Assistant Community Add-on: motionEye - #557 by pauldavidkelly

In a nutshell:

  1. Activate the addon, set up admin and user username and passwords.
  2. No need to set motion_webcontrol to true. So I left it at false.
  3. Go to add integration and set your address to then the users and…
  4. Pop!

I don’t know why the URL is not prefilled when I have motionEye add on installed already…

I restarted home assistant and now the integration is listed in “new devices discovered” the rest of the setup is relatively easy.
I’m still tweaking motion eye since I’m having trouble getting motion detection working as desired however I have 2 questions:

  1. Why is the webhook automatically configured to use “localhost” instead of the IP address of my home assistant instance? Is it because it is possible that motion eye is installed on another host?
  2. The newly created “action” entity is disabled by default, I have to enable it manually to see webhook calls from motion eye.

I thought the “action” entity was just the method for sending commands to the camera (up, down, left, right, preset1, etc)? Did you really have to turn that on to get any webhooks to work?