Setup of https'ed Pi-Hole integration

The documentation on how to set up the integration lacks fundamental information.
It took me an hour to figure out that you have to enter the IP address in the host field – there is no DNS resolution done if you enter a valid hostname.

If your Pi-Hole is secured by SSL (mine is behind an NGINX proxy doing the SSL stuff - plain http:// requests get rejected) you have to make sure that you

  1. uncheck the Verify SSL certificate box in the config_flow since the entered IP address can’t pass a check against the certificate’s hostname and
  2. configure a catch all clause within your proxy (I had to add a –until now never needed– 308 permanent rewrite pointing to the Pi-Hole’s https address).

After setting up the integration (Pi-Hole’s API key you find in its settingsAPI / Web interface behind the Show API token button) you’ll be unable to visit your Pi-Hole from HA’s device page if your proxy is configured to deflect IP adresses (host names only).

This integration (and its documentation) could really use a little more :heart: from the devs…


Can someone tell me where/how to add the Pi-Holes API key in the integration? I can’t find where to do that.


bump, i too cannot figure this out

Update: I was able to figure it out. I have 2 Pi-Hole instances running on separate pis. I just updated pi-hole (command "pihole -up) and then removed and re-added the integration in my HA machine. I think mine was last updated around sept 2022. This time it prompted me to enter the API key right after entering the Pi-Hole info.