Setup on Synology NAS with remote access

You create your domain in external acces -->ddns. your domain will look like, say, After that you create proxies and all those links will be, say,
But, first you must test if domain brings you to synology main login page. If not, you must set port forwarding accordingly - if you connect via http then it’s port 80, for https it’s port 443 - that port must be forwarded to local IP of your NAS.
If those websocket fields are not populated it’s maybe because ddns has not been set yet…?

@Protoncek yes I did exactly what you wrote, but I can not access this domain.
Only one thing I think that maybe wrong is the value on the right side by setting WebSocket.
In my config, I set it to 267, but really do not know what correct value is?
What do you think?

Moreover, I’d like to ask you if we can use DDNS and quickconnect in Synology simultanously?
Currently, I enable quickconnect mode too.

I have both enabled, yes: quickconnect and ddns, so you can have them both.
Well, here my knowledge pretty much ends… i can show you my settings for websocket:

@Protoncek it is the same for me with
But here I speak about, we have to Create WebSocket, and for it a value is necessary.

@Protoncek Now, I can set up WebSocket as your system, but still have not access to this domain.

I think I have to create a router for this.
One question:
How can I set up this? Which option?

I don’t quite understand what you mean by “”? If you mean access to your synology nas it’s not “” but just “” (what you defined in ddns section) - this is access to your NAS. All other accesses are with a word before that, like “”, then, say, “” for video surveillance if you’d have one. You don’t need to setup any proxy for NAS access, only DDNS and router port forwaring. Proxy is only for other things. Port forwarding is necesarry to set up in your (or internet provider’s) router, not in NAS.

@Protoncek I can explain it as follows:

  1. in External Access, DDNS sector I registered: “”, I selected Auto for External Address and then generate a certificate for it
  2. By Reverse Proxy I create
    a) “” for DSM interface and Destination Port 5001 to 443, WebSocket as your guide, and then its certificate
    b) “” for HA and Destination Port 8123 to 443, WebSocket as your guide, and then its certificate

It is all I did in NAS configuration, but no access on both of them

I try to find out if it is possible to do any “Port forwarding” in my router FritzBox but I did not find anything.
Do I miss anything here?

part a) is not necesarry. As said, you must access your NAS with domain “”. Only for HA access you must create proxy entry.
I don’t know fritzbox routers, so i can’t help you here. But, every router has port forwarding. Look in section where you have WAN access set. It should look like a page with entry of name, internal IP, internal and external port and choose between TCP, UDP or both. this picture shows my case for Asus router. Last line is for synology. IP is internal IP of Synology server

I’m not sure if it’s mandatory, but check if you have this also set in your NAS (HTTPS, Reverse proxy part):

@Protoncek Thanks. I will ask avm for port forwarding in Fritzbox.
But have another question:
In your Router Configuration I found 3 entries and the last one for QuickConnect, which use also port 443.
In my case I can access my NAS using QuickConnect, That means for me that my router already make this kind of port forwarding somehows. If so I should find the word QuickConnect or Synology in FritzBox Configuration.
What do you think?

In my Router Configuration, I tried to insert Customer port like you
Local port 443 to Router port 443
But I have an error like

But I do not know how to enable it…

There are 3 entries, but only first one has “enabled” checkpoint. I think that quickconnect works differently than ddns access, so i think you don’t need port forwarding for it, only for ddns and proxy.
You won’t find any quickconnect in fritzbox unless you manually entered it there.

Regarding last error: Automatics from NAS (router part) more or less only works for Synology routers. I can’t make it work for my Asus RT-AX88U (says not supported), so you must do all manually in router. So forget “router” part in synology nas.

@Protoncek Now I am able to enable my router FritzBox for port forwarding, so I see something in NAS / Router Configuration like yours. But I still do not have any access from internet.

how can I insert this to HA?
PS: now I can access DSM per internet, But can not access HA. I think I have to configure it in HA, but I do not know.
Could you help me? Thanks

Copy/paste into configuration.yaml and restart HA.

what does “” mean exactly? the address of my NAS?
If it is the address of my Docker, how can I find it? Thanks

This is IP segment. This number means that you have IP of your nas (and all other devices) in the range from to while is router address. If you have, say, IP of your nas 192.168.1.xx then this entry would be


@Protoncek thank you very much for your explain and help. It works now by me.

1 Like

I have the same problem. Is this mandatory with the router configuration on Synology with port 443? Or what was the solution?

If you want to access your synology (and all other things within proxy entries if you created them) then you MUST enter port forwarding in you router, yes.
Why? Because for https port is 443 (same as port for http is 80). So all traffic with https will look at port 443 settings when it “hits” your router. So if you don’t make that entry router won’t know where to send this request and it will discard it.
An example for Asus routers: by default port 443 is directed to Asus AiDisk, if enabled - it’s a network drive (flash or HDD drive, connected to router’s USB port). So, if you don’t change anything and enter your DDNS name you will get Asus network drive login screen, if it’s enabled. If not, nothing will happen. I’ve had this set up back then before i bought Synology.