Setup ssh. but sudo not found

I setup. SSH. Finally i got my Putty to work. but when into the Pi3. i tried sudo apt-get install libudev-dev
-ash: sudo not found So try it without sudo
-ash: apt-get: not found

I’m in a similar boat where I’m trying to follow tutorials which seem to be outdated for because these sorts of commands aren’t working. I did read somewhere that because we’re logged into the RPi as ‘root’ we can leave out the ‘sudo’ but same as you, I tried this and still didn’t work

Your very limited on what you can do inside of You can’t add any new packages because there are no package managers available installed, so you cant uses apt-get. Which makes ssh’ing into your pi very limiting because there’s only a hand full of commands available to use.

To see the commands available type in
ls /bin

So the only real way to change anything is to add add-ons and changing you config.yaml file.


Ai, then i should start over with the normal HomeAssistant package.

If you want. is a really cool project that allows for easy add on components that can be easily updated. It also has the ability to take snapshots of the current state of your system. You just have to work within limitations. All new packages have to work inside of a docker container. Which allow for quick sharing of the project that can’t brake your system because there inside there own isolated containers.

To add extra containers that aren’t default just go to the Add-ons page and theirs a little input filed where you can add the location of other add ons.

Example of a repo with extra add ons.

First of all you are using Debian based tools, ResinOS use apt not apt-get and also sudo is not needed.

Secondly this is for devs only so if you don’t know what you are doing it is better not to ssh into the base OS. It is more than likely that if there is an update it will simply wipe your changes.

Third, you add stuff to the base OS while you most likely want to add things to the Home Assistant docker/container. So I would suggest you look into how to modify this container instead (keep in mind that you will need to apply those changes to every new version).

First of all, i do not like the use of ssh as i normally use Mac, I do not like to lend a PC, I can not program at all, I’m a professional electrician, can solder transistors, fix it, fix hardware failures, but I can not program completely. My experience is that I could add Zwave with the conventional Home Assistant through the addition of Libraries (all according to descriptions of others). In addition, RFXTRX and Zwave are also most used in domotics environments. At Hassio I did not get involved. That with that docker and container I can not explain how that goes. In itself, that would be the best because you can also add Plugwise modules, for example.

This is from the homeassistent io site:

For some exceptional devices, the /dev/ttyAMA0 will not be detected by udev and are therefor not mapped with docker. So you need explicit set this device for mapping to Home-Assistant. Execute this command on ssh add-on:

$ curl -d ‘{“devices”: [“ttyAMA0”]}’

After that, you need change usb_path to /dev/ttyAMA0.

So i think it is sometimes needet to use SSH (for this moment i dit not do this yet)

I use hassio and i got Zwave manager but there is no node connected.

See logs:
The following errors have been logged this session:2017-08-25 12:10:28 WARNING (MainThread) [homeassistant.setup] Setup of sensor is taking over 10 seconds. 2017-08-25 12:11:05 WARNING (SyncWorker_6) [homeassistant.components.zwave] zwave not ready after 30 seconds, continuing anyway 2017-08-25 12:11:06 ERROR (SyncWorker_17) [plexapi] (401) unauthorized 2017-08-25 15:07:21 ERROR (MainThread) [homeassistant.core] Timer got out of sync. Resetting 2017-08-25 15:10:47 WARNING (SyncWorker_17) [openzwave] Can’t lock controller for command : add_node 2017-08-25 15:11:24 WARNING (SyncWorker_18) [homeassistant.components.zwave] zwave not ready after 30 seconds, continuing anyway 2017-08-25 15:11:27 WARNING (SyncWorker_19) [openzwave] Can’t lock controller for command : add_node 2017-08-25 15:13:29 WARNING (SyncWorker_11) [openzwave] Can’t lock controller for command : add_node 2017-08-25 15:14:02 ERROR (SyncWorker_12) [homeassistant.core] Error doing job: Future exception was never retrieved Traceback (most recent call last): File “/usr/lib/python3.6/concurrent/futures/”, line 55, in run result = self.fn(*self.args, **self.kwargs) File “/usr/lib/python3.6/site-packages/homeassistant/”, line 1030, in execute_service service_handler.func(service_call) File “/usr/lib/python3.6/site-packages/homeassistant/components/zwave/”, line 363, in add_node_secure network.controller.add_node(True) File “/usr/lib/python3.6/site-packages/openzwave/”, line 657, in add_node return self._network.manager.addNode(self.home_id, doSecurity) File “src-lib/libopenzwave/libopenzwave.pyx”, line 4244, in libopenzwave.PyManager.addNode (openzwave-embed/open-zwave-master/python-openzwave/src-lib/libopenzwave/libopenzwave.cpp:31062) TypeError: an integer is required