Hassos / Setup Zwave with RPi 3B+ - once anew not working out of the box


I’ve messed up with my zwave devices, so I’ve started an install from scratch, thus deleting my cmdline.txt and config.txt that worked fine (means : razberry board was detected)

Now, with the hassos 1.12 image (tried as well 64 bit as 32 bit, but was using 1.11 when it worked), the zwave stuff is not working. Root cause : no /dev/ttyAMA0 nor /dev/ttyS0 in /dev ! only a /dev/tty

As per many hits on this forum, I’ve added
to the config.txt on the first partition of my sdcard and removed the console= statemend in the cmdline.txt

Then I’ve tried adding
 usb_path: /dev/ttyAMA0
anyhow in my configuration, hoping that some script would map the device into the container. Rebooted, but no change

hassio hw info shows the expected output :
core-ssh:~# hassio hw info
   “result”: “ok”,
   “data”: {
       “serial”: [

Which leadsd me to think that the razberry card is basically available to the main system, it’s just that it is not mounted into the core-ssh container

I’ve found this post Setup ssh. but sudo not found
which suggests that there is the need for a curl command to enable the /dev/ttyAMA0 link
Running the command, I get however a 401: Unauthorized code :frowning:

Other hits on this forum suggest adding udev rules, installing libudev etc… however all these things don’t seem to be possible within the core-ssh container, maybe I would need to jump into anther level of docker container to perform this, but I have no idea how to do this.

Anybody having a good hint at what’s the small point I’m obviously missing ? Seems like I did things right 3 weeks ago, but didn’t write them explicitely down (or wasn’t aware that it would matter).

Many thanks

Update : reverted back to image v1.11 but problem still remains - not ttyS0 no ttyAMA0 visible within the core-ssh container :frowning:

Topic solved - in factwhen SSH’ing into the hass.io, one enters the SSH container, where not all devices are visible.
Having hassio hw info display the tty devices is proof enough that they’re available, and can be used.

In the end, I had to remove the /config/.storage/core.config_entries file, in order for the modifications of /config/configuration.yaml to be taken into account