Shelly 1 Tasmota Configuration

Hi all,

I don’t know if this is the best forum to post this in. If there is a more appropriate one please let me know and I will move this there.

I have been trying to set up a Shelly 1 with Tasmota for the past couple of weeks. I have been flashing the Tasmota sonoff.bin file to the shelly as outlined in this video:

The problem is I never get a stable product out of it. Sometimes I flash and I can’t even connect with Termite. Other times I flash and I can connect with Termite, then the web interface, but after a few hours the shelly reboots with an exception and eventually does this enough times that it just locks up and dies.

This morning the new flavor is I flash and I get what I think is an endless bootloop/connecting to AP.

The log file showing what happened yesterday when the shelly eventually rebooted enough to lock up is below:

Anyone have any ideas what is wrong?

All help appreciated!

There might be someone that comes along to help you but it may be better if you go to the tasmota support on github and post it there.

I haven’t tried to put tasmota on a Shelly so I don’t really know any of the pitfalls associated with that hardware.

It’s a little late but just for future reference you don’t need to flash tasmota onto a new Shelly since the factory firmware supports local MQTT control now.

I used Atom with Platformio to flash Tasmota on my Shelly1’s. Used the Source Code 6.3 from the releases page to compile.
The Shelly1 is working very good, had no problems so far.
Maybe you used the dev branch of Tasmota Code?

Thank you for the thoughts.

Yeah haha, I know the factory firmware supports MQTT control. Sadly, I started messing with flashing Tasmota on the Shelly before they did that update. Don’t have a lot of time to experiment with this stuff so it gets drug out over a lot of time lol.

So I tried what you suggested. Greatly appreciate the suggestion! I downloaded atom, and installed the platformio addon/extension/whatever it is.

I redownloaded the source code file for Tasmota-6.3.0 just to make sure I had a fresh one. I selected sonoff.bin in platformio.ini and changed the COM port to the right one for me. And I added my wifi details to my_user_config.h.

Saved all that and hit upload in the PlatformIO drop down and it failed. Please see the output after all of the compiling steps below:

Linking .pioenvs\sonoff\firmware.elf
Checking size .pioenvs\sonoff\firmware.elf
Building .pioenvs\sonoff\firmware.bin
Memory Usage ->
DATA:    [=======   ]  67.0% (used 54856 bytes from 81920 bytes)
PROGRAM: [=====     ]  47.6% (used 499211 bytes from 1048576 bytes)
Configuring upload protocol...
Looking for upload port...
Use manually specified: COM3
Uploading .pioenvs\sonoff\firmware.bin
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
*** [upload] Error -1
 [ERROR] Took 36.70 seconds
Environment sonoff-minimal      [SKIP]
Environment sonoff-basic        [SKIP]
Environment sonoff-classic      [SKIP]
Environment sonoff-knx          [SKIP]

Environment sonoff-sensors      [SKIP]
Environment sonoff-display      [SKIP]
Environment sonoff-BG           [SKIP]
Environment sonoff-BR           [SKIP]
Environment sonoff-CN           [SKIP]
Environment sonoff-CZ           [SKIP]
Environment sonoff-DE           [SKIP]
Environment sonoff-ES           [SKIP]
Environment sonoff-FR           [SKIP]
Environment sonoff-GR           [SKIP]
Environment sonoff-HE           [SKIP]
Environment sonoff-HU           [SKIP]
Environment sonoff-IT           [SKIP]
Environment sonoff-NL           [SKIP]
Environment sonoff-PL           [SKIP]
Environment sonoff-PT           [SKIP]
Environment sonoff-RU           [SKIP]
Environment sonoff-TR           [SKIP]
Environment sonoff-TW           [SKIP]
Environment sonoff-UK           [SKIP]
Environment sonoff              [ERROR]
 [ERROR] Took 36.70 seconds

I also tried uploading Tasmota-master in the same way, and that one successfully uploaded. However, when I went to the serial monitor the shelly looked to be in a bootloop.

You’re nearly there. The error “espcomm_open failed” has 2 potential causes:

  1. The Device is not in “upload mode”. Make sure that when connecting the USB Adapter the GPIO0 is shortened to GND
  2. The upload port (COM3) specified in platformio.ini is wrong. Check whatever port your adapter is using in Device Manager (if you’re in Windows?)

You’re correct. I’m apparently getting frustrated enough with this that I’m starting to make stupid mistakes. I didn’t have GPIO0 plugged in.

Plugged that in and reflashed, it flashed successfully, but now when I look in the serial monitor it is just boot looping. See some snippets below:

It starts off with all of whatever this is:

n�␂� �␜�l␛�l`␛$��r��l␌␜����␜�l�㌜␛␂�␛␂�␇b��␌␜�␂��␌␜�␌␜�␌␜�␌␘␒␂�␇r��␌␜�␂��␌␜�␌␜�␌␜�␌␘␒␂r��␒�␘��Ē␌␜�␂��␌␜�␌␜��␜�␌␘␐���r��␌␜�␂��␌␜�␌␜�␌␜�l`␛$

Then after it does that for a bit I get this:

00:00:00 Project shelly Sonoff (Topic sonoff, Fallback DVES_8AB9FC, GroupTopic sonoffs) Version 6.3.0-2_3_0
00:00:00 WIF: WifiManager active for 3 minutes
00:00:00 HTP: Web server active on sonoff-6652 with IP address
ets Jan 8 2013,rst cause:4, boot mode:(3,7)
wdt reset
load 0x4010f000, len 1384, room 16
tail 8
chksum 0x2d
csum 0x2d

Don’t really understand why it is using the wifi manager, I gave it the ssid and password for my wifi in “my_user_config.h”

Then it gives me the gibberish above again followed by this:

Exception (0):
epc1=0x4025bdfe epc2=0x00000000 epc3=0x00000000 excvaddr=0x0000002a depc=0x00000000

ctx: sys
sp: 3ffff8d0 end: 3fffffb0 offset: 01a0

3ffffa70:  4025bddd 3ffffa80 00000008 40240332
3ffffa80:  00000010 4024031d 0000008a 000000b9
3ffffa90:  000000fc 58323025 0000007d 3fff5734
3ffffaa0:  00000000 4020ff0f 3fff5734 3fff5734

At that point its basically looping through all of that over and over. Do I maybe have a broken shelly?

Can you connect to that Wifi and browse to that IP ?

Originally, sort of. When I first plugged it in and saw the output on the serial monitor I got my phone out and looked for the wifi to connect to it. I tried connecting a few times, but before my phone could fully connect the shelly reboots and I lose it.

I tried plugging it in again, and now it seems to be dead. No output on the serial monitor at all and no wifi on my phone to connect to. I do in fact have everything plugged in like I should this time also. haha

Sounds like this Shelly1 really has an issue. I’d suggest posting the Stack Trace over at the Tasmota Github Page, maybe the Shelly can be rescued somehow (reset 1 ?)

Okay, I will do that. Can you help me with posting the stack trace? I’m not sure how to do that. And should I post it as s an issue or somewhere else?

You could post this as an issue on github

Also, I read that you can reset the Shelly 1 by pressing 5x on the switch connected to the Shelly shortly after it has been powered on.

I have exactly the same problem - out of 4 Shelly 1’s, I got one working, the other 3 are doing exactly as yours. All of those 3 booted Tasmota initially as they should, I was able to configure WiFi and MQTT, but after a short while they went dead and monitoring with the Termite I can see what seems to be a bootloop. The 4th one has been holding up for a week (fingers crossed that it stays this way).
Flashing Shelly is so easy (Flash ESP easy) that I do not understand what can go wrong…

I only have the one, but yeah, I’ve pretty much given up on it. I like the Shelly 1 better because it is safer, and a little easier to setup for flashing, but at this point I think I’m going to stick to the sonoffs. Definitely let me know if you ever figure out what the problem is though.