Shelly 1PM firmware issue


I am trying to use a Shelly 1PM power relay.

I have finished the WiFi configuration, but when I try to add my integration, I get “unsupported firmware version”.

This is what the built-in web server says:

The current Firmware version of your Shelly device is 20191219-114622/1047-long-id-for-shelly-devices@d05667c7 No newer firmware available.

Here is the full web UI:

I understand that the integration requires firmware 1.8 or later. How does this date-based version compare to that?


For me it somestimes helped to make one or two device reboots from the settings page. Then it should show a newer firmware version and you should be able to update.

Latest FW Update for 1PM should be 20200827-070450/v1.8.3@4a8bc427

I just did 3 more rounds of reboot, and still nothing.

Shelly tech support suggested to test it on a WiFi hot-spot provided by a cell phone, but I am sitting at a different city now, so that would be problematic.

Well, until then, at least the REST API works…

Have you resolved the problem? I have the same

Since that time, I have seem with multiple Shelly units that firmware update fails when the units are on the “normal” Wi-Fi network (ie. on the Wi-Fi provided by the usual APs of the buildings). However, when I put them on a WiFi network created by my cell phone (as a WiFi HotSpot), then the FW update works.

Also, after the initial update is done, further updates also worked on the normal infrastructure network, when using the /ota API endpoint manually.

By the way I have abandoned the 1PM, and moved on to use the Plug-S instead. (Easier wiring plus it also measures consumption, not only current power usage.)

1 Like

I just faced the same issue.
Problem was that I had disabled the shelly cloud service from the beginning.
After setting up the cloud service it instantly showed an available update for the device.

1 Like

Hm, I have a similar issue. When setting up the device it is on a old firmware version, not compatible with Home assistant. But it is stating to have the newest firmware installed. Restarts are not helping. I also tried to reset and start from scratch. The device is not connected to the Shelly cloud. But trying to connect it to the cloud only ends up in an error message. :frowning:

you can force ota upgrade using the device http api.
Generate OTA url using this portal:

Of course the device must have access to the Internet


Thank you, that did the trick for me. I was able to update to a newer firmware version. It is now working properly.

Did you loose total consumption entity values after firmware update or does this Shelly not provide that?

I have both, the current power consumption (power) and the history (energy)

Okay so firmware updates still reset all recorded usage data… nice Allterco. Not.

It’s not surprising me. such devices are not intended to store values infinitely.
You can calculate energy from power values from data recorded into db

Yeah I now need to find a way to use the total consumption value from my InfluxDB. Anyway could be so easy.

Just wanted to let you know this was a great tip!
I’ve just received my black Friday order from Shelly and the two plugs had really old 2019 firmware.
So old it wouldn’t update itself, but I also didn’t want to register to the cloud.
I used the link you gave, had to take a bit of a gamble about which firmware to choose, but it went smoothly.
Now they are also auto-updating (without cloud registration) which is great.

1 Like

Wonderfull! That finished all my troubles! :smile:

Revisiting, as I hit the same issue. I recently installed several Shellies 1PM and all works fine, but one…
This is stuck at some old FW version (same as all other come with) and does not recognize thet any new version os available. Additionally it does not detect time zone, nor update the time from SNTP. All settings are copy/paste as for other working modules (except of IP, obviously). I tried to force FW update OTA as described below, but also this one fails with message:
To me it looks a bit like lack of internet access, but I can’t understans why it could be… routing diagnostinc from my router shows proper configuration. Obviously device works properly on local networ and I can acces web inteface and also integrated it into HA (though due to lack of time, I’m not sure if energy consumption reporting will work and this is the major reason for installing this device).
I also tried to change IP, reboot device few times, even reset to factory settings and configure again, but no change. Is there any resolution to this?

Replying to myself… Today i tried to play directly with Shelly web API and do not know what happened, but after a week of troubleshooting everything suddenly started to work as expected. SNTP server was able to access internet and set the time, firmware check showed recent available version and update went smoothly… Apparently something got unblocked on device just by using this API - only status checking, not trying to enforce any action on the device.